Still having update dialog prompts in kiosk mode using --disable-dialog

Hello,

I’m using Brave on screens in exhibitions, touchscreens & signage.
Those are running on Linux Ubuntu 22, latest Brave in kiosk mode, loaded on startup by a systemd startup command.

Note that the same bug occurs with latest Brave on Windows 10 at another exhibition.

And i use the following command-line flags

[Desktop Entry]
Type=Application
Exec=brave --kiosk "http://localhost/" --incognito --allow-insecure-localhost --unsafely-treat-insecure-origin-as-secure --allow-running-insecure-content --disable-pinch --disable-popup-blocking --disable-translate --disable-infobars --disable-session-crashed-bubble --overscroll-history-navigation=0 --disable-sync-preferences --autoplay-policy=no-user-gesture-required

Yet, when a Brave update is released, i still get the “please update” dialog.

Am i missing something?

Would a kiosk / signage version of Brave be a good idea?

Thanx

The Exec= line you cited does not include the --disable-dialog option you mentioned in the title. Are you sure you eventually included it?

In any case, I tried it and it made no difference; I still get the update warning.