Still can't recover my bookmarks

What do you see if you open your terminal and type cd .config?

It selects the folder. I already checked there and there are some files inside the “brave” folder, but a lot of them seem to be blank documents. And nothing bookmark related as far as I know

Can you share a screenshot of the terminal when you enter .config/brave?

It only says:

bash: .config/brave: Is a directory

To confirm, your path (enter pwd to view your path in terminal) should look something like:

So from terminal, you should have entered:
cd .config/brave
cd .config --> cd brave

Now, can you enter the ls command and share a screenshot of this folder?


Thank you!
So this file here, session-store-1
holds your browsing data - including your bookmarks. Can you tell me if that file is empty?

No, it’s not. It has a lot of text in it.

Excellent. So, this means that your bookmarks are not gone. Great news right? Let’s get them into your new Brave install now, shall we?
Follow these instructions to import Brave Muon (old) data into Brave Core (new):

Hmm. I’m trying to but it doesn’t seem to work. I only get the option to select an HTML file, so I made a copy of that and added a .html at the end, but the bookmarks are still not there.

Which Ubuntu distribution?

I’m on Ubuntu 18.04.1

I’d like to quickly make sure we’re all on the same page here. Please correct me if I’m off-base here-

  1. You have: “New” Brave build ( likely release build - v0.58.21) installed
  2. You previously had: the “Old” (Muon) Brave build installed that had your browsing data on it
  3. The Old (Muon) Brave has been uninstalled from your machine
  4. Your browsing data however (session-store-1) is still present.
  5. Attempting to import bookmarks/settings using the built-in importer in “New” Brave does not display Brave (Old) as an option to import from (which it should).

:point_up: Does the above seem correct?

  1. I just checked and I have the 0.56.12 version installed
  2. Yes
  3. Not sure if it’s fully uninstalled, as I was able to access the old Brave by clicking an executable found in my files
  4. Yes. I made a backup just in case it gets deleted
  5. Exactly. I only have the option to import an HTML file. But I tried changing the file extension and my bookmarks were not there

Thanks for the additional info. A couple things:
Definitely upgrade to the newest release of Brave. If it doesn’t automatically update, open the menu and select About Brave. This should initiate the update process.

A couple more things to try here to get your bookmarks back (again, they’re definitely still there). Try the following:

  1. Find and launch the old (Muon) version of Brave. If you’re having trouble locating it, the executable should be located (assuming you haven’t moved it) in ~Downloads/usr/bin
  2. Now, check again to see if your bookmarks are there. I know you’d mentioned trying this before and not seeing them but humor me on this.

If you DO see your bookmarks in the old Brave (yay!), do the following:

  1. Open the main menu
  2. Select Bookmarks --> Export Bookmarks
  3. Choose a destination easy to find and save your bookmarks there as an HTML file (this should be done by default unless you change the file type manually).
  4. Close Brave Muon and open Brave Core (new version, hopefully your updated v0.58.21 version)
  5. Navigate to Settings --> Bookmarks --> Import Bookmarks and Settings...
  6. Select Bookmarks HTML File and choose the newly exported HTML file from Muon.

If you DO NOT see your bookmarks in the Muon (Old) Brave, let me know, and also let me know if - when you first installed Brave (Old/Muon) - did you install through the terminal or via snap? I have at least one more idea/suggestion if the above doesn’t work.

Again, I appreciate your patience and willingness to correspond and work through the issue with me. Always nice to see someone else willing to put in a little work :slight_smile:

Okay so I tried to update but it didn’t do anything. If it’s necessary to have the latest version I was thinking of reinstalling everything but I’m not sure if that’s gonna make it harder for me to get my bookmarks.

Yeah, I tried again and no, they weren’t there. One thing worth mentioning, I used the search feature on my files and there were a bunch of brave executables, I couldn’t open the majority of them, even while using Nautilus. The few that worked opened the old version of Brave. I’m quite a beginner so I’m not sure if this may be the reason my bookmarks don’t appear. I couldn’t open any of the executables found in the location you mentioned.

I don’t remember exactly but I’m pretty sure I installed it via Ubuntu Software. That or via the terminal, but I’m leaning more towards the former.

1 Like

I think it’s time to go the nuclear route. Try the following:

  1. Make sure you have a copy of your session-store-1 file stored safely somewhere. In fact, to be safe go ahead and copy that entire folder (holding that file).
  2. Uninstall everything Brave related. Everything - new build, old builds and browsing data for both. If you still see Brave directories floating around - delete em.
  3. Now, once Brave has been wiped, go here to download a 0.24x version of Brave (Muon)
  4. Install it, navigate to your .config/brave path, and replace the session-store-1 file found there with the copy of your old session file you saved in step 1.
  5. Relaunch Brave - you may even want to reboot your machine - and check to see if your bookmarks appear (they should).

From there, if they appear you can follow the same steps above to export BMs and import into Brave Core:

No, they’re still not there

I was just about to respond to your post about the .deb file not working then it disappeared.
Did you get it to run/install?

If so, just to confirm, you replaced the session-store-1 file in the new .config/brave folder created after installing the .deb file, correct? Also, did you happen to save the whole .config/brave folder, or just the session file?
EDIT: Also cc @sampson for backup