Spotify web player doesn't work


#1

When navigating to https://play.spotify.com, I’m referred to this site for configuring my browser for using Spotify. The configuration options for Chrome doesn’t apply to Brave Beta (for linux), although the browsers are closely related, so I currently have no way to configure Brave Beta to start the Spotify web player.

Maybe the Spotify web player relies on Widevine plugin too, like Netflix does, meaning we’ll just have to wait for Widevine support for Linux · Issue #413 · brave/brave-browser · GitHub to be completed?


#2

Unfortunately yes, @proton.
Both Windows and macOS log into Spotify without issue. It’s highly likely that its all related to Widevine. Are there any other specific configurations it requires?


#3

@Mattches, I think @proton said that they’re on Linux. :grin:

Yep, Spotify need DRM plugin to be able to play it. And Widevine support for Linux is not available yet. You can follow the progress on the link you shared above @proton.

Thanks
:slightly_smiling_face:


#4

Sorry if I was unclear - I saw that they were using Linux. That’s what my “Unfortunately, yes” was in reference to.


#5

Thanks for the replies. I’ll just wait for that Github task to be completed. In the mean time I’ll just keep using good, old Firefox.


#6

Ah yeah. My bad. :sweat_smile: Somehow I missed that. Hehehe


#7

There is a webcompat issue logged for Spotify

This would be fixed on Linux as well once Widevine support for Linux · Issue #413 · brave/brave-browser · GitHub is fixed allowing Widevine to work on Linux.


#8

I must be over looking something. I’m also trying to play music through the browser on Windows, and i’m not able too. I allowed the widvine extension that showed up in the URL bar, it pushed me through to all my playlists and stuff but whenever I try and play something, it’s not working?

I checked the content settings, and cleared cache and restarted the browser.

Edit: Also noticed that whenever I do have spotify web player open in a window, and close that tab, Brave crashes. :frowning:


#9

Nope, you didn’t overlook anything. I just looked into this and am able to reproduce the error. The problem seems to be linked to cookies being blocked by Shields but that shouldn’t be happening.

I’m going to bring this up to the team, but if you’d like a workaround so that you can at least listen to music, open your Shields panel (lion icon on the top right) and under the Cookie Control setting, select Allow all cookies. The page should reload and you should be able to listen as intended. I know that allowing all cookies isn’t ideal but its the best I’ve got for now until the team looks at this.

Thanks for reaching out!