Specific sites not loading on main profile

Description of the issue:
Specific websites are not loading at all. i.e. americanexpress.com

How can this issue be reproduced?

  1. When type in and auto-populate in the address bar many websites that I frequented in the past, the sites no longer load. Typically the website will load if I instead do a search from google or I include www. This is not the case on the same computer with any other browser. This started happening over the past month.

Expected result:

Brave Version( check About Brave):
I’ve been on the latest version of Brave - V1.33.106

Additional Information:

Can you please try clearing your cache/browsing data in Settings --> History --> Clear browsing data? Then test any of these sites again and see if they load correctly.

That seemed to do the trick. It was odd that it happened. Thanks!

@Mattches Hey, actually this keeps recurring. It seems to be strictly sites that are entered through the address bar. Sites load fine via a google search or a bookmark, just not when entered via the address bar. Sometimes adding www seems to fix some sites, but not all. I don’t want to have to keep clearing the cache every time.

Do you have any extensions installed in the browser at this time? If so, can you tell me which ones and whether or not disabling them resolves the issue?

Hi @Mattches disabling extensions and restarting doesn’t change anything, same with incognito/guest mode.

I noticed a few sites that redirect by default aren’t resolving - so americanexpress.ca is what I’ve always typed via auto-populate, which in my region goes to https://www.americanexpress.com/en-ca/

this is the case for several sites. the sites themselves work, it’s the way Brave handles the initial address.

Thank you for the information. Would you also mind trying to visit these sites using a new browser profile and see if this yields any different results?

Hi @Mattches yes, even with a brand new browser profile I’m having the same issue.

I don’t have account to test, What exactly shows up ? This is what I’m getting (NZ Location),

worked for me using link

It’s not the specific site itself, it’s sites that requires a redirect of some sort.

It’ll take a 30-90s to resolve after hitting the link and then it says this:

This site can’t be reached

americanexpress.ca took too long to respond.



again if i type the final link it works. And the links work on other browsers on the same device, as well as other devices on the same network. It appears to be a Brave issue for me.

https://www.americanexpress.com/en-ca/ is the Canadian site, does that work?

Thanks, but again, the issue is not the ultimate site, if i have the correct full URL for sites that redirect I can just enter that in and it works, the issue is with links that require a redirect.

i.e. anything from twitter that uses their short URL, this for example - https://t.co/GC9cXDxtMu redirects to https://crypto.com/nft/ on any other browser, but for Brave it’s not doing that for me.

Just test the site (redirection) via a NZ IP, under a new Brave profile. I pasted americanexpress.ca a few times

worked for me clicking the image tab took longer to load then link above

if I click that twitter link it brought me to crytpo.com nft page

Thanks all, I get it. It works for you as expected. It doesn’t for me.

are you using SecureDNS? in brave://settings/security ? or does it work in private window mode?

I figured out what it was, as I noticed links were working in firefox and safari, but not chrome as well. Which led me to private-relay being turned on in MacOS. All links resolve correctly now. But is this a known issue, that brave/chome browsers don’t work with Private Relay for iCloud plus turned on?

Is there a bug report on https://bugs.chromium.org/p/chromium/issues/list ? Would look there, any fixes like this would come via upstream Chromium