Sorry but back to Firefox I go

Been using Brave for a couple of weeks but I could not figure out what was going on yesterday. My older i5 system running Windows10 Pro w 8GB of RAM and 10 tabs open in Brave Version 1.3.115 Chromium: 80.0.3987.87 (Official Build) (64-bit) was using 92% of the CPU. At the time I was watching a video on YouTube but stopping that did not help. CPU usage for Brave went down briefly to 58% but then climbed back up to 90% CPU usage.

Opening Firefox and the same tabs and FFox rarely hits 20% CPU usage. I Have also had Brave after using it all day just lock up while watching a YouTube video so bad that I had to kill off every Brave process.

@fedup,
This is likely a Hardware Acceleration issue, can you try disabling HWA in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

So the high CPU usage and YouTube viewing both caused by hardware acceleration issue? Was this an issue that was introduced in recent builds? I did not notice this until the last week or so.

Sorry but I tried Brave for a day and had to revert back to Firefox. Pages constantly loading and never completing. Some pages timing out perhaps due to the loading issue (spinning circle) around favicon. I need a browser that I do not have to fight with and the current builds of Brave have issues here.

@fedup,
I totally understand the frustration and I don’t blame you for not wanting to fight/troubleshoot the browser when common tasks that should function seem to be…well, malfunctioning.

That said, I believe the issue you’re encountering is fixable. If you still want to work through it, here are some tests to try:

  1. You asked if HWA could be responsible for both high CPU usage as well as the YT viewing issue. The answer is yes, it can be responsible for both. I have seen this setting cause both of these issues seperately, as well as at the same time and it’s definitely worth testing against, considering it’s just one toggle to flip (Settings --> Additional --> System --> Hardware Acceleration).
  2. Often times, long page load times can be caused by bad data stored in the browser cache. Try clearing your cache data/browsing data and see if this helps the slow page loading.
  3. If you have any extensions installed, one (or more) of them may be in conflict with the browser/browser settings – can you try creating a new profile (using the profile menu, next to the main menu, or Main menu --> Create new profile) and see if the browser behaves the same way (make sure you close the original browser window you had open so that you only have the new fresh profile window open)? This is a quick and easy way to see if the issue revolves around extensions since the new profile will not load any of them. Easier than disabling them all individually on your main profile.
  4. Last but not least, it may be worth downloading/installing the Beta build to see if it behaves the same way. This will tell us whether or not the issue is related to Brave directly, or related to your current installation specifically.

Again, I do understand if you’re disenchanted with the idea of jumping through these hoops just to get the browser functioning properly. That said, I do hope you decide to try the above tests and, if so, please let me know what you find out :slight_smile:

1 Like

I am still testing individual extensions to see which if any are causing this issue with sites not fully loading. Only time will tell whether anything will come out of it to point where the issue is. I did the clearing of the cache to start off with. This is all with HWA disabled.

1 Like

@fedup,
Appreciate your diligence!

Well I may have narrrowed the issue down to one extension. However the inability to delete that google.com cookie to force logging out of Gmail on browser shutdown and now notifications from YouTube are no longer working has made me make Firefox the default browser here.