Sorry! Ads are not yet available in your region

ads-bug
#1

Hi,

I just have updated to Version 0.65.74 - unfortunately Brave tells me that ads are not available in my region (Germany). Before the update ads were working properly. My virtual balance is gone as well and I cannot see how many ads I got…

2 Likes
#2

seems like change from nightly version transfered to dev version
unfortunately, no response from developers…

https://community.brave.com/t/earn-tokens-dissapeared-after-last-update/54959/3

1 Like
#3

@uiuiuiui @creator22 Ads are enabled in Dev. What is the OS (Region) and OS(locale) set in your machine? Just viewed Ad on 0.65.74 brave dev vesrion.

Please make sure your OS REgion and locale is set to one of the supported country (US, Canada, UK, French, and Germany).

Thanks!

1 Like
Earn tokens dissapeared after last update
#4

@gsarvadnya - thanks a lot for your help! seems like the detection method has been changed as it worked before, I have corrected mentioned entries and it is working fine again

2 Likes
Developer browser no ads
#5

@gsarvadnya - thanks - working again!

1 Like
#6

Hi, I changed the setting to Germany (Duitsland), but I still don’t get ads. I use Brave Dev (0.65.74).
What’s the problem? Please help.

Knipsel

#7

@Herman_N Can you please send me a screenshot of Region & Language settings page from your OS? Also can you check the below post which will help you to debug the issue.

Thanks!

#8

Hi @gsarvadnya,
thanks for answerring my question.

Herewith I send you the screenshot of my Region & Language settings. Hope it’s correct. If not, please send me an example of the screenshot that you mean. FYI, I live in the Netherlands and I changed the region/language settings yesterday from Netherlands to Germany (Duitsland) in order to make Brave ads work.

I saw the debug instructions, but if I have to execute these it’s not ok. It’s actually ridiculous to switch the region & language settings for this. But to execute a lot of instructions what is described in the post it’s like the stone age.

Hope you are able to solve it in a normal/user friendly way. Thanks a lot in advance :slight_smile:

Best regards.

1 Like
#9

Hello,

I am having the same issue with my browser. Currently I am using PulseSecure for VPN and I have tried to connect from 3 different locations (US / UK / Germany) and I do not get any ads and getting the same error as the original poster. (Sorry! Ads are not yet available in your region).
Here is the screenshot from the Regions page.


Tried to uninstall and reinstall and not helping out…

Thanks in advance
Best regards

#10

i’m from italy and i also have this problem, how to solve it?

#11

I have this same problem with region. I live in Germany.

#12

@dawienzzi @dan83m @dorukm @Herman_N

Edited the post made it clear.

Please make sure that the IP + locale criteria will enable the ads. Both the conditions should match one of the supported country (Germany, Canada, US, French, UK). In windows locale is taking from the Administartive setting Region, locale which is set in Region should match one of the supported country (Germany, Canada, US, French, UK).

Thanks!

#13

so setup in italy doesn’t work?

#14

btw how i can send the brave i will earn through brave rewards?

#15

thank you very much. It´s work.

1 Like
#16

having some issues on ubuntu linux - im in USA & have brave beta installed. is there something i need to set on my OS additionally to let it know im in the USA…?

#18

Ok thnx @gsarvadnya,

I changed both region and language to US and the message ‘Sorry, ads are not yet avaiable’ didn’t come back. That’s great!

But now I am still waiting several hours for the first ad that will popup. I set ad setting to 5 per hour. I have restarted my computer 2 times and I use Brave Dev 0.65.74.

Please help.

Capture

#19

@Herman_N Ads notifications should not take so long. Can you please look into the below post and follow the instructions suggested by @Mattches and check the chrome_debug.log file to check whether notification is made or not.

Also, please make sure the changed locale reflected in the Sys info page. After changing locale if you don’t restart the machine the locale change will not reflect.

Also, please check what option is set for Focus Assist, If it is set to OFF ads should be shown on the browser itself (bottom right corner). Please rever back if it doesn’t work

Thanks!

1 Like
#20

Checked everything, region, locale, focus assist. Still the same issue. No ads showing up in the Netherlands :frowning:

#21

I cannot seem to use this in Ireland either. I think it’s pretty ridiculous that I have to set my entire PC locale to “supported” countries (and lie) to use the most important part of the browser that makes it different from the rest.