Some Shortcut keys do not work on Dvorak-Right-Handed Keyboard

Description of the issue:
The browser does not recognise shortcut keys from the top row of a Right-handed dvorak keyboard correctly. This keyboard has some letter keys assigned to the top row (number keys on the QWERTY). See layout here (

When keys from the top row are used as shortcut keys, the browser uses the QWERTY layout instead of the Dvorak-Right-Handed layout. This does not affect the keys in the other rows, which return the correct key with shortcuts. It also doesn’t affect text while typing, only shortcuts.

So there is no way of accessing Cmd+P or Cmd+F in the browser while using a Dvorak-Right Handed Keyboard.

This may also affect the use of Dvorak Left-Handed Keyboard layouts, But I have not tested that.

How can this issue be reproduced?

  1. Switch Keyboard to Dvorak-Right-Handed. Open Brave browser.
  2. Press Cmd+P on the Dvorak-Right-Handed Layout (corresponding to cmd+9 on the QWERTY). If nine or more tabs are open, the browser switches to the last tab instead of printing. If <9 tabs are open, nothing happens. No print dialogue opens.
  3. Press Cmd+F on the Dvorak-Right-Handed Layout (corresponding to cmd+8 on the QWERTY). If eight tabs are open, the browser switches to the 8th tab instead of opening search. If <8 tabs are open, nothing happens. No search dialogue opens

Expected result:
2. Print option pop-up is supposed to show, but does not happen.
3. Find option is supposed to show, but does not.

Brave Version( check About Brave):

Version 1.45.127 Chromium: 107.0.5304.110 (Official Build) (arm64)

Additional Information:

This appears to affect all applications running on chromium, but only on MacOS. Here is the issue (it is marked as resolved in the chromium bugs, but remains a bug on Brave)

1 Like

Hello there @SqueegeePasture please accept my apologies for this inconvenience. Could you please try changing the USB port where the device is connected and make sure the keyboard drivers are up to date?

Also try perform the actions on other Browsers to see if the issue repeats there. If the issue only happens on Brave, try disabling Hardware Acceleration in settings to see if this resolves the issue.

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Let me know if that works.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.