Some extensions not working because javascript is not enabled


Computer: Linux laptop, POP!OS (debian/ubuntu based)
I use the 1password extension for keeping my passwords. I tried to sign into my account and got a message that it needs javascript to work. I read Brave documentation and went to the Privacy and Security section of settings and found javascript. The title was javascript and the status was blocked. I opened up the section and there were two parts: block and allow. Next to each option was add - where you could add a url to be blocked or allowed. I put in the url for 1Password. when I hit enter, the 1Password url showed under Allow and there was no url under block. When I closed settings and tried to enter my password for 1Password, it didn’t work. I tried to take a screenshot but it turns out that my screenshot extension needs javascript also. So no screenshot.
When I exited that section, the heading still said javascript: blocked.
There must be some way to enable javascript.
How can this issue be reproduced?

1.follow the instructions in Brave’s documentation.
2. in allow: enter url of the extension
3. close settings and try using extension

Expected result:
Well, my expected result is to use my password keeper, but that’s not what I got.
Brave Version( check About Brave):

Version 1.27.111 Chromium: 92.0.4515.131 (Official Build) (64-bit)

Additional Information:
I had a previous version of Brave before which I unfortunately had to remove. Under that Brave browser I was able to use all my extensions including 1Password

Note difference between HTTPS form and HTTP form of entry. HTTPS uses port 443. HTTP uses port 80.


Adding HTTPS address:

https://www.some_domain_one.com:443


Adding HTTP address:

http://www.some_domain_two.com:80


More detailed example of a way to add a website, using Brave Browser:

I used a New Private Window in order to visit the password manager website, Bitwarden. There, I clicked on the tiny Padlock icon to the left of the URL address . . . that action resulting in a pop-down menu:

Screen Shot 2021-08-12 at 10.25.14 AM

Note that JavaScript is set to Block (default).

I clicked on that selection, in order to change that setting to Allow:

Screen Shot 2021-08-12 at 10.21.23 AM

Next, in another New Window, I went to:

brave://settings/content/javascript

and the entry for Bitwarden is:

Screen Shot 2021-08-12 at 10.40.15 AM

Some caution, here . . . notice the sunglasses(?) . . . because I went to Bitwarden, using a New Private Window, the entry in the JavaScript listing, will be removed when I close all the Private Windows of Brave Brower -or- Quit Brave Browser.

IF I had used a New Window, instead of a New Private Window, and then clicked on the little Padlock to the left of the Bitwarden address, and chosen for JavaScript, Allow . . . THEN . . . the entry at

brave://settings/content/javascript

Screen Shot 2021-08-12 at 10.42.36 AM

would NOT be removed as a result of closing Brave Browser windows -or- Quitting Brave Browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.