(Solved) WebRTC no way to turn it off


#1

I just signed up for a VPN.
Nord and I have been checking the security of this VPN
I have come across that WebRTC is active and no way that I have found to disable it in Brave.
I know your team is going for security so having my IP leak via WebRTC is a big deal.
Tested at IPleak.net.
I tested in firefox after using about:config and turn off media.peerconnection.enabled to false and it is secure.
I really like your browser and would like to use as my main browser but with this security concern and the issue I reported with Roll20.net I can’t do so yet.
No screen shot but your can test this yourself at the above address.

Technical Info
MacOS 10.12.5
Brave Brave 0.17.16
rev 2d2ee2f
Muon 4.1.8
libchromiumcontent 59.0.3071.115
V8 5.9.211.38
Node.js 7.9.0
Update Channel dev
os.platform darwin
os.release 16.6.0
os.arch x64


#2

Please open the top left lion icon and see Fingerpriningt protection is enabled. It is disabled by default.


#3

Hello @MadDawg

You can also try disabling WebRTC.

Go to the advanced settings for the WebRTC extension or,

1 - Type ‘about:config’ into the URL bar.
2 - Search for ‘media.peerconnection.enabled’
3 - Double-click on the entry to change the Value to ‘false’.

You can also Install the Disable WebRTC add-on.

The uBlock Origin Browser Extension prevents WebRTC from leaking your local IP address.

►https://github.com/gorhill/uBlock#ublock-origin


#4

about:config doesn’t load in Brave


#5

This worked thank you for the help


#6

Hi @MadDawg,

Thanks for confirming that’s worked. I’m going to close this thread since it’s solved. If you have another questions or find some bugs, please open a new thread for them.

Thank you,
:slight_smile:


#7

I believe what @Jay-Oz mean is a workaround for Firefox. Since Brave currently have no about:config. :slight_smile:


#8

This topic was automatically closed after 3 hours. New replies are no longer allowed.