(Solved) User Agent string does not contain any reference to Brave, but gives the user agent string of chrome dev 59

closed

#1

User Agent string does not contain any reference to Brave, but gives the user agent string of chrome dev 59:

The user agent string Brave sends is “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.109 Safari/537.36”

Servers consider this as Chrome Dev 59, not as Brave 0.17.13!
You should send an user agent string that distinguishes Brave from Google Chrome.


#2

Hi @lvni900,

As far I know, at the moment Brave is using Chrome UA string. So yes, many site will thinking you are visiting using Chrome. Also, if I’m not wrong, Brave will change their UA and use their own UA in the future.

Hope this can answer your question.
Thank you,
:slight_smile:


#3

Yes eljuno, I believe it shows up as Chrome, because otherwise sites might work improperly because of Brave being small still.


#4

Brave uses Chromium so sites should load the same in Brave as in chrome but it is also a privacy thing if I remember correctly, not letting the website know that you are using Brave :slightly_smiling_face:
If a website knows that you use Brave it can in theory block you from viewing the site with shields up :slight_smile:


#5

All, I’m going to close this thread since it’s already answered.

@lvni900, if you have another question or face any issue, please open a new thread.

Thank you,
:slight_smile:


#6

This topic was automatically closed after 105 minutes. New replies are no longer allowed.