(solved) Stuck in loop - Not able to claim rewards

I’m stuck in loop. I’m not able to claim rewords. As I click on claim I get error.


Please help

@milo298 .

https://community.brave.com/search?q=oops%20something%20wrong%20android%20order:latest

I’ve been facing the same issue. Stuck in the loop. Clicking on the claim button returns “Oops something is wrong Please try again” This has been such since 10 or 11th.
I tried to look for related posts but seems there aren’t much and support team hasn’t come across it yet because there has been no response from the support team in any of the posts related to this issue.

1 Like

Does your device pass Safetynet? You can test here: https://play.google.com/store/apps/details?id=org.freeandroidtools.safetynettest&hl=en_US&gl=US.

Yes it does pass the test. Here is a screenshot provided of the test. The blurred part is just an ad and nothing related to the test.

1 Like

@milo298 @Xeta Can you try claiming from brave://rewards and see if it works from there?

2 Likes

Thanks I tried this way and it helped.

Is it something new? I’ve never known that rewards could be claimed this way.

1 Like

It’s solved for me. @Aman_M suggested a way and it helped.

It’s been there for quite some time as an alternative way. It may not work all the time but generally works if claim has been failing for some time.

1 Like

Is it available just for Android or present in desktop as well?

Your comment lit up a bulb in my brain.

I’m a root user and I’m in AOSP development. which clauses me to change roms frequently. Some roms don’t pass and even though some may pass they for sure will have this issue.

Solution for people like me:

  1. Hide root in magisk for Brave
  2. Download universal safety net fix from github and install via magisk manager.

If your company policy allows you can suggest this fix to other users also.

Thanks Steeven
My issue is solved.

Cheers!!!

1 Like

I did tried that but sadly didn’t work for me.