[SOLVED] Open in play store app link

Description of the issue:

Steps to Reproduce (add as many as necessary):

  1. Go to https://play.google.com/store/apps/details?id=com.spotify.lite&hl=en with Brave for Android.
  2. Click on the button OPEN IN PLAY STORE APP
  3. It will open a new tab but the play store app is not opened.

Actual Result (gifs and screenshots are welcome!):

Expected result:
The play store should be opened to be able to download the app.

Reproduces how often:
Anytime

Brave Version(See the About Brave page in Settings):
Brave 1.1.2, Chromium 75.0.3770.143

Mobile Device details
OnePlus3T
Android/iOS Version
Android Pie

Could you try the following:
Go to your Android Settings, click on Apps, then on Google Play Store.
There, find the setting “Set as standard”. There should be an option called “supported URLs”. Click it and select “in this app”.
Was this already selected? If not, does this fix your problem?

[I see all options in German, so some translations could be different]

Edit: Does this happen with every app or just with Spotify Lite? I ask because this app is not supported in every country, so this might be triggering the error.

Yes the option was already selected.
I tried with this app and I have the same behaviour: https://play.google.com/store/apps/details?id=com.plarium.raidlegends
No issue with my 2 other browsers (Via and Chrome beta).
Thanks.

@Primokorn,
You may also want to check your device settings as well as they may be dictating this type of behavior over the browser itself.

The Menu/Settings/Location for these settings may differ by device so I apologize if this isn’t exactly correct, but you’ll likely find these settings in Device Settings --> Apps --> Default Apps --> Set as Default

Here, you’ll want to see if you have an option like Open links in apps somewhere, which should be enabled. Additionally, you’ll want to find the Play store app in the list of installed apps in this menu and ensure that Go to supported URLs option is set to In this app and that play.google.com is entered in the Supported web addresses section.

Further, I opened an issue a while back to include this type of control in browser settings directly (to avoid situations like this):

@Mattches
Device Settings > Apps & notifications > Default apps > Opening links > Google Play Store:

  • Open supported links: Open in this app
  • Supported links: play.google.com and market.android.com
  • Other defaults: No defaults set.

It’s indeed a missing feature IMHO. Once again I don’t have this issue with other browsers so it’s not a problem with the system settings.

My posts are hidden because they have been reported as spam!! What the hell is going on?

No idea why your posts have been marked as spam, but here is a new try to fix your problem:

Could you click on the “Open in Play Store App” button again? On that blank site that opens, press the lock in the top left corner. Press “Website-Settings” and then “Clear and reset”.
Now, go back to the website that has the “Open in Play Store App” button. Without clicking it, repeat the same process to clear and reset it’s data.
After reloading the page, does anything change when clicking the green button again?

No, it doesn’t help either.
Does it work on your device? If so please give your Android version.

It works for me on Brave 1.1.2, Android 9.

Does it make a difference if you try to open it from a private tab?

OK I recorded a log and found the source of the problem.
Brave needs to know that Google Play is opened on my device (the permission was not allowed).

2 Likes