[Solved]Brave not launching on Debian Linux

solve
closed
linux

#1

Hello all,

I’m experiencing issues with the latest Brave browser (0.15.310_amd64) not launching on Debian. This is happening on both the stable branch and testing branch. I tried installing using the graphic installer (gdebi) and from the command line using dpkg. Services appear to be running and I get a bit of hard drive activity when I attempt to launch the browser but it never opens.

Not sure if it matters, or if this helps, but Brave runs great on the latest releases of Fedora, Ubuntu, and Lubuntu.

Thanks for any help you can give with this.


#2

@chadmccullough Could you try launching Brave from terminal and see if it throws any error?


#3

Thanks for the reply. Not sure why I didn’t think to try this. Following is the output when I attempted to launch from the terminal:

[978:978:0601/200121.052447:FATAL:zygote_host_impl_linux.cc(107)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox.
Aborted

I launched with --no-sandbox and the browser launched.

Thanks for the help!


#4

Please enable enable userns in your kernel with the following commands as sudo user. Its not recommended to run without --no-sandbox

echo 'kernel.unprivileged_userns_clone=1' > /etc/sysctl.d/00-local-userns.conf

service procps restart

Then you should be able to launch browser from terminal or the app itself.


#5