Solved: Brave goes non-responsive on session restore

After continuing to wait through the day and upgrading to 1.46.138 without change I tried moving Brave’s directory away for a blank start. This sort of worked, in that Brave ran. Then I tried moving it back without success. Finally, I tried deleting the contents of “$brave/Brave-Browser/Default/Service Worker/CacheStorage/”, whereupon all windows/tabs loaded happily.

Description of the issue:

When I start Brave and ask it to restore my session, it opens the windows, but then fails to load any contents, not even toolbars, etc. That leaves a blank X11 window.

I suspect the issue is some recent tab that worked on load while Brave was running and/or too many tabs/windows for Brave to load.

How can this issue be reproduced?

  1. Open Brave
  2. Click “Restore Session” when offered
  3. Watch windows for session open, but remain blank

Expected result:

Windows load toolbars and page contents

Brave Version( check About Brave):

46.134 (brave-browser_1.46.134_amd64.deb)

Additional Information:

Leaving Brave open, but unresponsive for ~1h has gotten one window to be closed by window manager without killing Brave. The issue is not my computer out of resources. Processor is running ~85% idle, 0-0.3% wait, and I have near 2GB completely untouched RAM, 0kB swap in use.

I can find two 12MB Session_$longstringnumbers and two 2.6MB Tabs_$longstringnumbers files. I suspect these are the session files.

I would ideally bring up a session window/tab list that I can sort through and select which windows/tabs to attempt restore.

The tab URLs and which window they are in are important to me. I don’t care about window size, position, where on the page I was, etc.

Looks like this may be somewhat similar to brave stops responding as soon as i open it - #3 by Alice2095, but in my case I can’t do anything at all.

3 Likes

@TorC Please accept my apologies for this issue. On this case, try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Let me know if that works.

Aloha Kevin,

Thanks for getting back to me. I had this happen once since, solved the
same way, and since then it has worked fine. Now on 1.46.144 (apt
version) and seems to have been fixed in somewhere in the intervening
time or there was something strange about my setup. A system upgrade at
the time of issue is potentially implicated, though that shouldn’t have
mattered, as I was on the Brave apt repo both before and after.

Tor

1 Like

HI again @TorC thanks for confirming this issue was solved. Should you have any other concerns please let me know or create new community post so we can further assist you.

Regards.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.