[SNAP] Tired of losing all my tabs and bookmarks

When I reboot my system or quit brave, I often lose all saved data for the past few days.

I tried to prevent this by bookmarking all my tabs before a restart. But when I opened again brave, I had the same session than few days before, and the folder I created was missing (because it wasn’t existing 4 days before).

I’m tired about losing all my bookmarks and tabs… I often create export and then import, but that’s a lot of logistic (because bookmarks are not merged but imported into new folders each times), extremely painful… This should be obvious that a browser should persist that kind of data.

I think I’m gonna stop using brave, even if I like it otherwise. That’s just too painful to use an amnesic browser.

@neustry ,

Reading over your earlier posts, some details re you Brave Browser installation and experience:

You use Snap in order to install / refresh / update your Brave Browser for Linux OS installation: https://community.brave.com/t/brave-refresh-failed-through-snap-from-1-27-111-to-1-29-76/280308/2

Brave Browser on your Linux machine, fails to remember / restore your Bookmarks, upon any Start or Restart of the browser: https://community.brave.com/t/brave-have-a-short-memory-lost-tabs-and-bookmarks/344110

In February, I asked: Did you go here:

brave://settings/clearBrowserData

and UN-CHECK everything? Quit Brave Browser. Start Brave Browser. And see what happens?

But I have not found info from you, that you have gone thru Brave Browser > Settings . . . and what you have chosen to Enable / Disable, that may affect the retention of your Bookmarks.

Suggest: With Brave Browser running, in a New Window, go to brave://settings/clearBrowserData

Examine all the settings for all three tabs: Basic / Advanced / On exit

Be certain that those settings are what they should be, for your usage. In time, you will have tested those arrangments, and figured out what you need, there.

Be certain for two of the tabs – Advanced / On exit – to Disable:

  • Passwords and other sign-in data (IF you are using Brave Password Mgr.)

  • Site and Shields Settings (unless, before the following steps, you decide that you initially do need to clear “Site and Shields Settings”)

Recommended at: brave://settings/cookies

  • Disable: “Clear cookies and site data when you close all windows”

  • Do not use: “Sites that clear cookies when you close them” (better to clear those cookie sources, manually: brave://settings/clearBrowserData)

Location of Brave Browser for Linux OS installation

The BraveSoftware folder to routinely be backed up, is in the path:

/home/[username]/.config/BraveSoftware/

Brave Browser Components are within component folders within the Brave-Browser folder, in the path:

/home/[username]/.config/BraveSoftware/Brave-Browser/

About those Brave Browser Components, in a Brave Browser > New Window, go to: brave://components/

I am using Brave Browser v1.37.116 for Mac OS, and the existance of Brave Components for your Brave Browser for Linux installation, should not be much different.

In the following list that I constructed, the layout is

[Component name] - Version: [number]

Component folder name: [name]

Brave Local Data Updater - Version: 1.0.139

Component folder name: afalakplffnnnlkncjhbmahjfjhmlkal

NTP Background Images - Version: 1.0.5

Component folder name: aoojcmojmmcbpfgoecoadbdpnagfchel

Brave Wallet data files - Version: 1.0.14

Component folder name: BraveWallet

Brave Ad Block Updater - Version: 1.0.1300

Component folder name: cffkpbalmllkdoenhmdmpbkajipdjfam

PKI Metadata - Version: 250

Component folder name: PKIMetadata

NTP Sponsored Images (US) - Version: 1.0.805

Component folder name: gccbbckogglekeggclmmekihdgdpdgoe

Crowd Deny - Version: 2022.5.9.1141

Component folder name: Crowd Deny

Certificate Error Assistant - Version: 7

Component folder name: SSLErrorAssistant

CRLSet - Version: 7333

Component folder name: CertificateRevocation

Safety Tips - Version: 2814

Component folder name: SafetyTips

Brave SpeedReader Updater - Version: 1.0.21

Component folder name: jicbkmdloagakknpihibphagfckhjdih

File Type Policies - Version: 50

Component folder name: FileTypePolicies

MEI Preload - Version: 1.0.7.1642025427

Component folder name: MEIPreload

OnDeviceHeadSuggest - Version: 20220402.439557842

Component folder names:

OnDeviceHeadSuggestModel
obedbbhbpmojnkanicioggnmelmoomoc (for Android)

Brave HTTPS Everywhere Updater - Version: 1.0.94

Component folder name: oofiananboodjbbmdelgdommihjbkfag

Autofill Regex Data - Version: 2021.8.17.1300

Component folder name: AutofillRegex

Brave Tor Client Updater - Version: 1.0.25

Component folder names:

biahpgbdmdkfgndcmfiipgcebobojjkp (for Linux OS)
cldoidikboihgcjfkhdeidbpclkineef (for Mac OS)
cpoalefficncklhjfpglfiplenlpccdb (for Windows OS? or Android?)

A component that does not exist completely, but appears in your Components list, may NOT have a Version number/value . . . and that can mean, the Component is missing or not properly being updated.

A chart maintained at GitHub, of Brave Components:

https://github.com/brave/brave-browser/wiki/Brave-Components

Your Bookmarks and Bookmarks.bak files should be in:

/home/[username]/.config/BraveSoftware/Brave-Browser/Default/

Use the stat command via the command line:

stat -F $HOME/.config/BraveSoftware/Brave-Browser/Default/Bookmarks

in order to retrieve info re the file, and see if the file modification date is changing, when you add or remove a bookmark.

Hi

@neustry Are you using synchronization?

Hi,

@289wk

About settings :

  • Everything is unchecked in the “on exit” section.
  • There are some things checked in basic and advanced tabs (browser history, cache and cookies) but I don’t manage to uncheck them, when I do I can"t save, so when opening the tabs again everything is checked as before.

About components :

  • Everything is up to date
  • Everything has a version number

About local folders :

  • There is nothing is /home/…/.config folder
  • As I use snap, my config folder is located at /home/…/snap/brave/current/.config
  • When I add a bookmark I see that bookmark files are updated

So when I saw that files were updated, I tried to exit brave badly (pkill -9) and when I opened again, this time my bookmarks (created lass than a minute before) was found. So maybe that this issue was fixed recently. Or maybe file are not updated after some times, or when an update has been made while brave was running. I will watch that closely for the next few days.

@CerealLover I don’t use synchronization feature as I’m not a big fan about cloud features. But that can be something that I will start to use if the issue continues to happen.

So thank you for your help, If I don’t get this issue another time at the end of next week, I’ll let you know that this is not an issue anymore

Hi, one of my last supposition seems to be relevant.

When I did my last test, I was using the folder ‘160’ that had the shortcut ‘current’ as brave was installed thru snap.

Today I saw that a new version was installed, the new current folder is now ‘161’. But as I launch brave when the current folder was ‘160’, when I killed brave and launched it again, it started with the 161 folder.

So, my bookmarks was saved in the 160 folder (I can see the last modified date). But these changes wasn’t applied to the new current folder. Giving the impression that bookmarks were lost.

So I can conclude that this is a snap specific issue, brave is not faulty here.

What kind of solution would ease that issue in your opinion ? Should I ask snapcraft for support ? But I think they can probably not do that much to mitigate the issue. Should I write a script to automatically copy file of interest from one version to the other ?

Easiest than scripting, I think I’ll just disable automatic update of brave. Then do a munual update when brave is not running. I will test that with the next update.

1 Like

In fact that doesn’t seem possible to disable auto-updates for a specific app.
I asked my question in the snapcraft forum and they suggest me to open a bug ticket here. Here is the link of the discussion : https://forum.snapcraft.io/t/disable-auto-refresh-or-hotswaping-config-folders/30070

Does that seems legit to open a bug ticket ? And if so how should I do ?

You can create a new issue report at Brave GitHub at the link below. Just be sure to follow the posting guidelines or they will close the issue.

There is an open issue that may be related. In lieu of creating a new issue, if this issue is related, you can post a comment there outlining your details and linking the snapcraft discussion for reference.

I don’t know anything about Linux installation and snapcraft so can’t evaluate which is the better option. Sorry. Just providing information per reporting issues on GitHub. Even though your issue is solved, can you please post an update on what you decided to do. Thank-you and take care! :smiley: