Smooth Scrolling Choppy?

performance

#1

Bit of a nitpick here, but I’m a big fan of smooth scrolling. I previously used it on Firefox were it was seemingly flawless when scrolling through any website I used. No issues at all, no lag.

However, I couldn’t help but notice the choppiness and frame tears when using it on Brave? I have it disabled for now but it would be wonderful if a feature such as this wasn’t noticeably slow in many instances. (such as YouTube and a few other sites).

This may also go for tab transitions when hovering your mouse over them. The concept of it is very nice and works the way it should be, but the fade-in effect is also choppy and you can notice a totally blank screen for a small second before being able to look at what’s there.


#2

@DannyBGood, would you be willing to provide a gif of the behavior you’re describing as well as your Brave version and OS?

You can use Licecap to record gifts. Its free, lightweight and very easy to use/setup :slight_smile:


#3

This may be a bit difficult to articulate, but as I said, this would be considered a nitpick for some.
My current monitor used to traverse Brave is 144hz, which of course displays many more frames than a globally-used 60hz could. However with this, users like myself are much more able to easily see these screen tears and stutters within the browser. (Again, this issue is non-existent in Firefox)

I attempted to record footage of these stutters with 60fps footage via OBS, but I don’t believe the results would be all that noticeable on a 60hz/60fps monitor so I’m holding back on showing an example. If you have a 144hz monitor somewhere I highly advise you to check out what I mean by using smooth-scroll on the YouTube comment section for just a quick example.

ALTHOUGH, I did find a website that measures stutters within a monitor and the browser, so I got some sort of proof here. https://www.testufo.com/

Using this in Firefox would display a consistent green bar titled “READY” at all times while Brave would more often than not get a yellow “Stutter in browser” label on it, showing that Brave may have a few cases of under-performance.

As for the tab transitions, I believe this could be a very similar nit-pick as the fade animation for 144hz monitors is noticeably unoptimized. It all boils down to displays and framerate I believe.

Brave Version: 0.23.31
OS: Windows 10


#4

I too saw the same halting behavior on Win10… running with an SSD … Hummmm


#5

Any chance you have “Enable hardware acceleration” disabled?


#6

Can confirm that it pretty much has the same result whether it’s turned off or on. And to prove it isn’t a case of low specs either, my PC is currently running on an NVIDIA GTX 1080 and a Ryzen 7 1800x CPU.