Sluggish/laggy webpage rendering from brave browser

Description of the issue:
Is it just me (device/RAM/CPU problem), or others are also getting sluggish/laggy performance from web surfing on Brave. To me for reason, I see a difference of few milliseconds on how it used to work 2-3 months back. I have some extra list turned on via brave://adbock eg., cookie list, annoyance list etc. Is it happening due to extra lists. Or is something related to brave rendering/ad-block code written in rust.
On android, it is very fast (compared to non-adblock browsers) and just the way it was earlier.
@fanboynz mentioned that some new improvements will come in the new versions of brave which will increase performance.

Brave Version( check About Brave):
Version 1.35.100 Chromium: 98.0.4758.87 (Official Build) (64-bit)

Are you using any extensions for dark mode like dark reader? I had a similar problem and turned out it was slowing down the rendering of pages with a lot of elements inside them.

This issue with Brave Browser Help Renderer hogging 100% of CPU has been going on for 3 straight years with hundreds of people complaining and making reports and support requests… and all Brave does is absolutely nothing and simply close thread after thread after thread.

I have been an I.T specialist and network engineer for over 30 years using thousands of different programs and applications yet what I see with Brave is the worst support from its developers that I have ever seen for any app or program in my life.

What’s he point of supporting or even using any application if its makers just don’t give a dam about its user base…

1 Like

Yes, I use dark reader extension not to burn my eyes by light mode. I will disable it/remove it and toggle on forced dark mode in brave://flags. Might work out.

There are 6-7 options in the " Auto Dark Mode for Web Contents

Automatically render all web contents using a dark theme. – Mac, Windows, Linux, Chrome OS, Android, Fuchsia


Eg., Enable with…, enable with…
Which one will render/give the same effect as dark reader extension

Try if it’s the real cause first by disabling it.

If it is you can create an exception for any page ure visiting that’s giving u problems or is already dark (clicking the X in the options). That’s how I’m using it.

Test in a clean profile, no changes in Brave Beta. PGO will should be enabled in these builds.

Your method seems to have worked. It has slightly increased the speed of rendering, earlier it used to take few more milliseconds to render. Currently, I am using dark mode via brave://flags.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.