Slow startip [tried all suggested solutions]

Description of the issue:
Running:
Brave 1.31.88
Linux Mint Mate 20.2
The program is extremely slow to start but only the first time, if I close and reopen it starts fine. Doesn’t matter if the system has been up minutes or hours, the initial start of Brave is the same. This occurs both if I click the icon or run from Terminal. It only occurs in the main browser i.e I have several pages I saved as standalone apps that do not display this issue. I cleaned my cache, I cleaned only “cookies and other site data” (other people had success this way), I have no extensions TO disable, I set Brave to empty my cache each close
How can this issue be reproduced?

  1. EITHER click the icon or type “brave-browser” in a terminal
  2. Wait
  3. Wait some more

Expected result:
Brave opens without a 1min+ delay

Additional Information:
output from terminal:
[1994:1994:1102/162734.301744:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
Failed to parse JSON adblock resources: EOF while parsing a value at line 1 column 0
[1961:2025:1102/162750.161665:ERROR:chrome_browser_main_extra_parts_metrics.cc(230)] crbug.com/1216328: Checking Bluetooth availability started. Please report if there is no report that this ends.
[1961:2025:1102/162750.162397:ERROR:chrome_browser_main_extra_parts_metrics.cc(233)] crbug.com/1216328: Checking Bluetooth availability ended.
[1961:2025:1102/162750.254625:ERROR:chrome_browser_main_extra_parts_metrics.cc(236)] crbug.com/1216328: Checking default browser status started. Please report if there is no report that this ends.
[1961:2025:1102/162750.360489:ERROR:chrome_browser_main_extra_parts_metrics.cc(240)] crbug.com/1216328: Checking default browser status ended.
[1961:1961:1102/162754.655153:ERROR:CONSOLE(0)] “Unchecked runtime.lastError: The message port closed before a response was received.”, source: chrome://newtab/ (0)

First, I would say upgrade to 1.31.91 which was just released. I doubt it will change anything but at least you’ll be starting from the latest.

Then, what if you disable Hardware Acceleration in Settings?

There are also some similar ideas here that you could try: https://simpleit.rocks/linux/ubuntu/fixing-common-google-chrome-gpu-process-error-message-in-linux/

Does using those cmdline options change anything?

Tried both upgrading and the cmdline options and still nothing

I tested a few other browsers too and same problem so I’m assuming is something on my computer not Brave itself. I run Linux through a vm on my Surface and Brave runs fine so my thought is to go through synaptic and make sure all the packages are the same which is taking rather a long time but oh well

1 Like