Sling TV doesn't work in Brave

Description of the issue
I am unable to watch Sling TV in Brave. Sling TV requires Chrome for watching on computers, so I would expect and hope that it would work in any Chromium browser. That doesn’t seem to be the case. I’m able to login and browse the TV guide and available VODs, but when I actually click to watch a show, I get an error:

Authorization error occurred. Please try again later. (8-12)

I have completely turned off shields for the site, and this still happens.

Important note: this site requires a subscription.

Exact URL of the website in question

The general URL is https://watch.sling.com. However, if you still need it for some reason, the exact URL of the most recent episode I attempted to watch is:

https://watch.sling.com/watch?type=linear&id=7ff829c6c63247ca957d669de8547e64&channelId=35b320ac77ce4a2fbaf685e401933dc1&action=start_over

Again, though, any show or episode has the same issue.

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)

Yes

Does the site function as expected when Shields are turned off? (yes/no)

No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)

No

Does the site function as expected when using Chrome? (yes/no)

Yes

What Brave version/Build are you using when you encounter the issue?(About Brave info)

Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)

@echosa,
Have you installed the Widevine plugin yet? It’s required for most streaming websites that have some DRM attached. Although I’m not sure why it would throw an authentication error if that’s the case.

Let me know if you’ve installed Widevine or not and I’ll reach out to the team to see if they know what’s . going on.

I’ll try that. How do I install Widevine? On the old Muon Brave, it was on option in settings. I don’t see it in the new non-Muon version.

The option to install Widevine should appear on the right-hand side of the address bar (apologies for the low-quality image):
image
If you don’t see this appear when you visit SlingTV, try going to Netflix.com or Hulu (even if you don’t have an account, sign-in not required) and see if the notification appears there. We’ve had some issues with it not getting displayed for every site that requires it.

1 Like

Awesome, thanks! It’s working now. I didn’t have Widevine installed, and it didn’t popup for Sling. Going to Netflix prompted me to install it, and doing so fixed Sling. Watching Sling was the only reason I used Chrome. Now I no longer need Chrome at all! Thanks again.

2 Likes

Excellent, glad that did the trick!
Please don’t hesitate to reach out if you have any further questions or concerns!