Sketchup App stopped working in Brave - works in Chrome

I’ve got Sketchup as a Brave App. Yesterday I couldn’t get in when opening the app. The Sketchup Logo is just spinning in the App, as if sketchup is loading, but nothing happens.
I tried deleting browsing data. No luck.
I went over to Chrome and started Sketchup from there. It runs just fine.
So, the problem is obviously with Brave.
What do I do next to get the Brave Sketchup App up and running normally again?

5 Likes

Adding my own reply here to raise visibility on this issue. Can confirm the same problem on ALL my Windows devices. Can also confirm that all other browsers are not experiencing this issue, only Brave on the last update.

Would very much appreciate an expedient solution as Sketchup Web is integral to my (and no doubt many other’s) workflow.

1 Like

Same issue. I tried allowing all cookies and fingerprinting as per a previous post but didn’t work for me. Chrome and Edge are fine but Brave not working. Used to work fine. Even totally disabling Shields didn’t work.

2 Likes

Same issue here and it’s very frustrating since I need to use sketchup for some school projects

2 Likes

Same issue here. Have tried all usual cleanup/debug. Posted in other forums and received only one pitifully officious response and no ack.
Sketchup will not load since the 3/20 update. Have heard same issue from folks on Win and on IOS. It works on all other browsers folks have tried (have heard of no exceptions). Many of us pay subs and expect this to function predictably in our workflows.
Help with getting this on to tier two support and out of the tier one “have you tried turning it off and back on” is appreciated. Now that two weeks have passed, an acknowledgement in Known Issues would be the most minimal expectation.

1 Like

I also am having this issue. I have had to switch to Firefox because of this issue. Looking forward to using Brave again when this is fixed.

I can confirm this happens with Windows 10, Manjaro Linux, and Linux Mint.

2 Likes

@Mattches @fanboynz wanted to tag as it’s been a couple weeks since topic created. When I tested, I can replicate. It requires an account to test. But once you login, it doesn’t do anything.

https://app.sketchup.com/app?hl=en or something along those lines would be the link. I’ve since deleted my account as did it just for test, so you’ll have to ping people on this topic if need more details.

@B.R.A.V.E also want to point out to you that you should always provide more details and be mindful of where you create topics. Yours should have been in Web Compatibility but instead you left it in Uncategorized.

In addition, things like links, screenshots, which OS, what version of Brave you’re using, etc come in handy while trying to get help and troubleshoot. As well as whether you tried in private window, if new profile makes a difference, if you could test in Brave Beta or Brave Nightly, etc. All of which I do suggest you trying to reply back if you notice any differences. Perhaps also try things like disabling hardware acceleration and all.

1 Like

https://github.com/brave/brave-browser/issues/37380 Logged a report, seems to be service worker related.

To users of sketchup, Has it worked previously in Brave? When did it stop working roughly?

1 Like

Approximately two weeks ago in late March is when I noticed not being able to use Sketchup Web in Brave. I have it set up on Windows desktop to launch as a browser application and initially assumed it was a Sketchup issue until I noticed it could run in Firefox.

Prior to the issue, it ran great and I daresay inside of Brave it was more reliable and performant than other browsers (It certainly runs slower in Firefox for example).

Can narrow it down to pretty precisely to around 20.-22. March?
Had a project prepared on PC before that at home - couldn’t open on the following weekend on my laptop (both running Brave).
It continued to not work back home on the PC neither after that.

1 Like

If someone wants to confirm (installing Nightly, test, and then uninstall between between each build). I think its a regression between 122->123.

Nightly v1.65.68 (Chromium 122.0.6261.111) Good
Nightly v1.65.69 (Chromium 123.0.6312.29) (No windows build, but probably BAD)
Nightly v1.65.72 (Chromium 123.0.6312.29) BAD

Just installed the Nightly Setup (installed version 1.66.70 https://brave.com/latest/) , and ran it (what I am posting from now), and no - Sketchup still won’t load still. Will try the older 1.65.68 to see.

Ok, installed the 1.65.68 release and its working 100 percent now!

v1.65.72 was that the first version that fails, you will need to uninstall the prev nightly version