Sites in Brave cannot see USB drives to upload files

ISSUE: Brave browser cannot see USB drive images to upload to social media sites or download items to the mounted USB drives. Other programs running Linux see USB drives fine. Web-mail and video host sites running in Brave cannot see USB Drives for upload either. Settings area doesn’t seem to have a “safety setting” for such to shut down… am I missing it? There’s a safety switch somewhere, and it isn’t obvious as to where…?

How can this issue be reproduced?

  1. Brave runs like a champ in Linux posting site images (render pages)
  2. Brave cannot see my USB drives to either upload or download.
  3. social media image, mail attachments, video uploads to Rumble.com, and Youtube, also download of files to save destination: USB drives are not listed.
  4. Open Office, Image Viewer, Telegram desktop, can all see USB drives mounted on activities and desktop.
  5. [follow-up] Both Chrome and Firefox see and access the USB drives fine.

Expected result:
Locate my mounted drives and allow me pull files to upload, or select folder for preferred storage location when downloading.

Brave Version( check About Brave):
Version 1.26.74 Chromium: 91.0.4472.124 (Official Build) (64-bit)

**Additional
I looked at this topic post, but it seems it timed out and doesn’t show a resolution:

@dpan,
Thank you for reaching out to us with this.
I’m wondering if Shields are getting in the way of the sites detecting any mounted disks. I know that there is an actual internal permission that must be set:

So first, I would go to Settings --> Additional settings --> Site/Shields settings --> Permissions and ensure that this isn’t toggled off for some reason. If it’s on, then I would try disabling Fingerprinting protection (device recognition) in the Shields panel when on a site that you’re wanting to upload data to and see if this makes any difference (change to Allow all...):

image

The path: “Settings → Additional settings → Site/Shields settings → Permissions” actually ends at “Additional Permissions”

Ask when a site wants to access USB… is “ON”
message says, “No USB devices found”

Fingerprint blocking options are:

  • Strict, may break site
  • Standard
  • Disabled

“Disabled” choice on Fingerprint blocking nets…
no change…
Restarting Brave to check restart of options.

After reboot for “shield settings” and “fingerprinting” disabled, Brave froze, had to be “force quit” and reloaded.

… and now Brave can’t see my OTHER HDD either.

@dpan,
Can you please tell me what Linux distribution you’re using as well as whether or not you installed via official packages or using Snap/Flatpak?

It’s the latest Ubuntu package… installed Friday, with auto updates (LivePatch) daily. Don’t know where to find the version number in this OS yet… got it.

Ubuntu 20.04.2 LTS
64-bit
3.36.8 Gnome system
X11 Windowing system

Just to confirm, you installed Brave following these instructions, typing all of this stuff in a terminal?

No, the Ubuntu package of Linux comes with an installer and Brave offers a Linux download link. The resources of drives is the only problem I’ve seen with Brave thus far. Like I said, Firefox and Chrome both show the USB drives as available and I can access them.

Perhaps the terminal instructions are what I’m missing?

Do you remember what that link was? Was it on a website or in a built-in Ubuntu app?

That was Friday… I’ll take a look.
With Linux installed, the link comes up on the page as a graphic.
Here is the “copied link” from the graphic:

If that isn’t what I had found Friday, I can’t remember where it was. It may have been listed in the software available once I got the Linux system up and running. I’ll take a look there…

The app labeled “Ubuntu Software” offers links to packages that you can just click [Install]… once I installed it was up and running. But the install won’t see my USB drives…

Next question, if I have to run through the Terminal instructions… where do I find a terminal in Linux… HELP… well, Isn’t any “help”.

Ok, thanks. It sounds like you’re using the “Snap” package that we maintain but that doesn’t work yet as well as our recommended installation steps. It’s a newer technology and it has extra limitations that need to be worked around for everything to work as expected and so it’s a work-in-progress for us.

We’ll see if we can reproduce the problem you are seeing in that version of Brave.

Kicking around looking for answers I also found this… (remember, I’m new to Linux). In the applications list is a “Ubuntu Software” app that lists available software AND installed software. “Uninstall” is an option as is the “PERMISSIONS” button… There are several options here that lead me to believe might quash seeing the USB drives.

I’ve tried the options, restarted Brave, powered down the system and restarted, no dice yet. See screenshot, but I’ve turned the following options to “ON”:

  • (ON) Read system mount information and disk quotas
  • (ON) network: allows access to the network
  • (OFF) access the NetworkManager service to read and change network settings
  • ** (ON) Access USB hardware directly**
  • ** (ON) (Read/write files on removeable storage devices**

I’d think those last two would have done the trick (duh)… but there’s still no access to the USB drives from Brave when I can see and access them from other programs!

Let me know if I can provide any other “breadcrumbs”!

Thanks for the assist…

One of my colleagues thinks he found the cause of the problem. We will be requesting the missing permission from Ubuntu.

If you wanted to get it to work now, you could run the following command in a terminal to manually grant the extra permission:

sudo snap connect brave:removable-media

However, if you’re not comfortable with the command-line interface, then it’s probably be to wait a few days and there should be an update that makes it work.

I’m not opposed to learning… especially if it’s ONE LINE of instructions!

I’ve been looking for the Linux Terminal window… haven’t figured out where to access that yet. Complete our “issue fix” by telling me where to find it?

:smiley:

I’ve since located the terminal, entered the command string you suggested. Linux asked for a password… even “man sudo_root” for the manual just tells me “Users are locked out by default”. I used my login and it seemed to take it as PW: on the terminal… I didn’t get an error message, anyway.

I ran the string you recommended, no USB access. I restarted Brave; no USB access. I closed everything and rebooted the computer; no USB access… although restarting seemed to hang a bit more, took longer, and seem to start more than once. Executing the command string, perhaps… but, once I was back into the OS up and running, I started Brave,

went to the social media site… No USB access. (sigh)
web-mail accessed through Brave… No USB access.

I’m done, I’ll wait and see if you guys can hack at from your end and I’ll wait for news in the coming update.

Thanks again.

2 Likes

Thanks for that. Glad to see you figured out how it all works :slight_smile:

We do have a few more permissions we’ll be requesting so hopefully it will start working once our permissions match the ones that Chromium has.

HI,

Just wanted to say that i was looking for a solution for this after getting Brave snap version through Ubuntu as well.

Running the command suggested by fmarier (sudo snap connect brave:removable-media) worked in my case.

I can’t figure out why it won’t work for dpan (also linux beginner here). The only thing that comes to mind is, maybe to check if there is any available update package for ubuntu in software updater?

I had a bunch of them the other day and that could make a difference, but honestly no idea.

Thanks dpan for bringing the issue up and fmarier for the quick solution.

I tried posting this morning again from Brave browser, which still can’t see my mounted USB drives.

I have bigger fish to fry this morning and I’m not familiar enough with commands, syntax, or switches in the Linux terminal window to figure out what or how the command string is supposed to go and just “pop in” and throw some code in the terminal… I’d likely take time away from my project, lose my train of thought, and end up wasting my time…

I’l deal with it when I have time to deal with it… until then, I’ll use another browser when I need to see my mounted drives. (sigh)… an issue that might be worth an update?

Working with Ubuntu and Linux for 10 days now, I’m running into more issues, THIS ONE has popped up in ANOTHER area… It may lend some insight to the Brave problem seeing mounted USB drives:

I fired up OBS for the first time in Linux…
https://obsproject.com/download
and setting up backgrounds and logos I couldn’t access my image files from the USB drives through the OBS system either.

So… I went into the DISKS app to see how things were set up (how I could screw with settings and make the system completely unusable…)

Here’s a screenshot of the EDIT MOUNT OPTIONS window for that USB drive. Maybe some string of code there is preventing programs from seeing it.

ALSO: being new to the Linux environment, would the file storage system (notably different than what I’m used to seeing in Windows [FAT32??], might the storage system have something to do with the packages NOT seeing the mounted drive?