Site Settings Do Not Persist on OSX

Using Macbook Pro on OX X 10.13.6 (High Sierra), site settings (autoplay media etc) do not persist after closing Brave 0.24.0 with CMD-Q.

Steps to Reproduce

  1. Choose “allow” or “deny” and check “remember this decision” at the prompt when visiting a new site or after restarting Brave.
  2. View the settings at Preferences -> security -> saved site permissions
  3. Cmd-Q Brave or restart computer.
  4. View the settings at Preferences -> security “saved site permissions” header and all settings are no longer visible. Prompt will reappear at all previously saved sites.

Actual Result

Expected Result

Reproduces how often:
Every time.

Brave Version(about:brave):
0.24.0

Reproducible on current live release (yes/no):
Could not discern–prompt never appears when visiting sites for first time.

Additional Information:

I’m unable to reproduce this error on OSX in Brave 0.24.0.
Saved Site Permissions persist as expected after closing Brave, Quitting Brave/ending process, or restarting Computer.

In your Private Data section, do you have any options selected to be cleared on close?

Yes. I had thought they were independent. If this is the issue we can close my bug report. Thank you.

1 Like

Go ahead and test to confirm. If it turns out to be the case I’ll mark this as solved and close the topic.
Thank you!

Confirmed. Thank you for promptly solving my issue.

1 Like

My pleasure!
If you have any other questions or concerns, feel free to create a new topic any time!