Site changes to dark mode when switching back to brave from other apps

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:
If I open any website that supports dark mode (probably through media queries), and have dark mode enabled on the phone, it opens in light mode by default. It stays in light mode even when I refresh the page. When I try to switch to another app and come back, the site briefly switches to dark mode and gets reset to light mode if refreshed

How can this issue be reproduced?

  1. Make sure you have dark mode enabled on your device, Enable Dark Mode (Experimental) turned off in Brave settings, and Theme in brave is set to System Default.
  2. Open any website that supports dark mode through media queries (like github.com). Website opens in light mode.
  3. Try switching to another app, then come back to brave.

Expected result:

  1. Website should’ve been in dark mode by default
  2. Website should not switch themes

Brave Version( check About Brave):
Brave 1.37.110, Chromium 100.0.4896.60

Mobile Device details
One Plus 6
Android 11 (Oxygen OS 11.1.2.2)

Additional Information:
I took a video recording https://imgur.com/a/C2PvYAh

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.