Shutdown delayed because crashpad never stops

Description of the issue:
When I shutdown my machine it takes ~2 minutes. Looking at the journal logs, I see that the culprit is the 90 seconds it waits for crashpad to stop:

Dec 21 22:32:55 klflote systemd[1]: session-3.scope: Failed with result 'timeout'.
Dec 21 22:32:55 klflote systemd[1]: session-3.scope: Killing process 4640 (chrome_crashpad) with signal SIGKILL.
Dec 21 22:32:55 klflote systemd[1]: session-3.scope: Killing process 4638 (chrome_crashpad) with signal SIGKILL.
Dec 21 22:32:55 klflote systemd[1]: session-3.scope: Stopping timed out. Killing.

Expected result:
Process should be killed and system should exit promptly

Brave Version( check About Brave):
v 1.33.106

Additional Information:
This post suggests to change the setting for “Continue background processes”; I have turned that setting off and my problem persists.

This post suggests turning off automatic crash reporting altogether, which I’ve also done; the problem persists.

I’ve tried killing the crashpad processes manually; from a shell kill command, they all correctly respond to SIGTERM. And then a machine shutdown occurs normally, without the 90 second timeout.