Shields block at least part of every single page I try to visit

I’ve been using Brave for awhile, and I’m about ready to give up on it. For at least a month now, every single page I open for the first time comes up with a notice that the page wants to “autoplay media,” and asking if I’ll allow or block it. This is regardless of my settings in general or for the site itself, I can’t get it to stop asking this. Sometimes it doesn’t ask until I’ve been on the page for awhile. When I respond to this, either the page reloads (slightly annoying as it re-loads to the top with anything I might have typed being gone); or, occassionally, Brave just completely closes (considerably more annoying as I have to try to remember all of the pages I had open.)

As of yesterday, I can’t fully open any Web pages unless I turn off the Shields for that page. If I don’t, I get only a bit of the page, and nothing works on it. This includes the Brave Community page that I’m on now. If the shields are up, the page doesn’t work.

Some of the pages did give a notice that they require Javascript to work.

In Google, if I have the Shields ON, the search results are in framed boxes down the center of the screen. If I turn the Shields OFF, the search results are on the left side in paragraphs, as they’ve always been.

I have NOT made any changes to any of my settings for months now, so I don’t see how this can be something I did. The constant request to autoplay media was annoying enough. Having the Shields block the workings of every page I go to it about the last straw :frowning: .

I’m using Brave
Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (64-bit)

I’ve really liked the ideas behind the Brave Browser, but it has to work. If anyone has any suggestions, so that I can keep using it, I’d appreciate it.

If you’re getting this type of behavior on sites like this one (community) then there may be more than just Shields issues at play here.

First, can you tell me how your Default Shields settings are configured? Settings --> Shields Note that this setting dictates how Shields are configured for sites when you visit them. This is opposed to changing Shields settings in the Shields panel in the address bar – these changes are specific to the site you’re on. More information on Shields here:

Can you also please tell me what sites specifically (at least some of them) you’re encountering these issues on so that I can test on my end and ensure that they’re not part of a larger/wide spread issue?

I’d like you to run a test for me to help narrow down the cause of the behavior. Simply create a new (can be temporary) browser profile and browse as you normally would using this fresh profile (ensure that you close the original/your default profile window once the new one comes up). The new profile will not have any additional variables – such as browsing data, cache or extensions – and we can rule out those variables entirely this way. If you use the new profile and are able to browse and view web pages without the issues you’ve been encountering, then the problem likely lies in “bad” browsing data stored on your original profile and/or a conflicting extension.

Okay… I’ve closed and re-opened Brave. I do this almost every day, as I shut down my computer when I won’t be using it for awhile (I figure the “nasties” can’t hack a computer that’s turned off :slight_smile: . )

Under Settings > Shields:
Show number of blocked items on the Shields icon: ON
Default view: Advanced View
Trackers and ad blocking: Standard
Upgrade connections to HTTPS: ON
Block scripts: ON
Cookie blocking: Only cross-site
Fingerprint blocking: Standard

As far as the sites, I’ve had problems on many… I was looking for some hardware today, so the sites are where I was today (second attempt at sending this… it bounced back saying Brave won’t allow that many links, so I “broke” the links into two parts):
www.menards .com- the search feature doesn’t work… there’s a notice that I need to enable JavaScript in my browser com - the main page looks okay, but after entering a search term and hitting enter, the display only uses the center half of the screen, with about a quarter of the screen blank on both the right and the left; and each entry has a border or box drawn around it. com - the search function doesn’t work - I type something, hit Enter, and what I typed just disappears.
www.facebook. com - I enter my user name and password, hit Enter, and it tells me it can’t process my request, and takes me to this page: []( alphanumeric string that I didn’t feel like re-typing :slight_smile: . com - all I see is a bunch of grey boxes - shows a few links, but nowhere to actually log in

All of the above worked just fine after I clicked on the Lion icon in the address bar, and either allowed all scripts, or simply turned off the Shields for the site.

The only page that told me there was a problem (rather than just not working) was Menards. I couldn’t find a setting in Brave to globally turn on only JavaScript… all I could find was the one under Shields for all scripts, which I certainly don’t want to turn on.

As I also said, for a while now, I’ve been getting, on pretty much every page, a pop-up box whenever I first go to that page after restarting Brave. That box says: " ‘pagename’ wants to Auto-play media" and I have a choice of Allow or Deny. I’ve tried to find some way to change this setting, either globally or just for the pages I want, but any changes I’ve made haven’t lasted beyond my closing and restarting the Brave browser.


I will look into the auto-play prompt issue.

For the rest of your issues, you can solve almost all of them by allowing scripts in the browser. If you’d like to keep scripts blocked by default, then you can enable scripts in the Shields panel which apply only to the site you’re on. You’ll find that most sites these days use javascript and that blocking scripts will often break the website.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.