Shield prevents New York Times login

I use Shield for browsing and this prevents me from logging in to the NYTimes.com website. I am a digital subscriber. When I turn Shield off, then I can login. But when I do that then I get all the ads and other garbage which Shield usually prevents.

When I try to login using Chrome, I can do so.

I have tried changing the Shield settings for the site but nothing works except turning Shield off completely. I’m not sure whether the NYT site configuration is the issue; or the Shield configuration. If anyone is a digital NYT subscriber using Shield can you tell me what your experience is. Has anyone noticed a similar issue with any other sites?

I’m not having any similar problems logging in to other sites using Shield. Just NYT.

This looks to me to be a windows issue, maybe linux as well. No issues with mac.

I can reproduce the problem on my windows vm using latest brave though.

Thanks. Yes, I’m using a PC. It also does this on my Android phone.

A member of the Reddit Brave support team suggested logging out, then setting Shield to “accept all cookies.” When I then opened the NYT site it automatically logged me in correctly. Go figure.

Worked fine here; with minimal extensions (ubo disabled on this site, and bitwarden).