Shield Blocks Instagram

bug
#1

Description of the issue:
Shield Blocks Instagram
Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to instagram
  2. Turn shield on,
  3. Photos are blocked.
  4. Turn shield off,
  5. Photo’s aren’t blocked.
    Actual Result (gifs and screenshots are welcome!):
    https://i.imgur.com/sWjGDq2.gifv
    Expected result:
    Photos to show
    Reproduces how often:
    100% of the time
    Brave Version(about:brave):
    https://i.imgur.com/KVejEhN.png
    Reproducible on current live release (yes/no):
    Yes
    Additional Information:
1 Like

Embedded instagram posts won't work as expected
Instagram não carrega Imagens
Embedded instagram posts won't work as expected
Instagram won't load photos
#2

@Jeandre,
Thanks for reaching out. However, I’m unable to reproduce this issue. I can login to Instagram and view content as intended in Brave release v0.60.45 using default Shields settings.

Can you share a screenshot of your Shields panel settings while on Instagram.com (you can type them out too if you’d rather)?

0 Likes

#4

https://pastebin.com/MJNyBrZC

^ This is in Incognito (it happens in normal browser too though) without any other non-default extensions running.

I right clicked and hit “Clear CSS Rules for this site” with no effect.

0 Likes

#5

I have another user reporting this as well via Telegram. @Mattches

Screenshot from user:

(Rao Lin)

1 Like

#6

Another user reproduced on mobile:

(Kevin)

2 Likes

#7

@Jeandre,
Are you on Windows or macOS?

0 Likes

#8

Also, for anyone experiencing this issue, can you close Brave, wait ~3 minutes, and relaunch and retest to see if the issue persists? Making adjustments on our end.

0 Likes

#9

I am on Windows 10 ver 1809

0 Likes

#10

@mattches @chriscat I’m on MacOS X 10.14.3 Brave Dev 0.62.8 Chromium: 73.0.3683.39 (Official Build) dev (64-bit) and have same result. Turning shields off I get the images. Same result with Brave Beta 0.61.34 Chromium: 73.0.3683.39 (Official Build) beta (64-bit) and Brave mainline 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit). Screenshot of fail (yes, I have prurient interests on Instagram, and I’m okay with it):

1 Like

#11

I’ve moved this discussion into Known Issues category as I’m seeing a good amount of duplicate posts. We will use this thread as “master” moving forward. Similar/duplicate threads closed in favor of this one:
Embedded instagram posts won't work as expected
Instagram won't load photos
Instagram não carrega Imagens

0 Likes

#12

Update:
This issue should have been addressed on our end, but it will require a browser restart in order to take effect. If you were directed to or are currently watching this thread:

Please restart (fully quit and relaunch) Brave and see if Instagram images/content is still blocked?
If so, please let me know so we can further asses the issue, thank you!

2 Likes

pinned #13
0 Likes

#14

If you’re still experiencing problems, we just applied another fix that we believe will fix it.

To ensure you’re on the latest ad-block list updates, please close and open the browser.

If you’re on Desktop, you can navigate to chrome://components and you should see an item called Brave Ad Block Update.

If that is on version 1.0.142 or higher then you have the fix.

Please let us know if you see any other issues, but this should fix you up.

Sorry for the trouble.

3 Likes

#15

@brian and @Mattches, Instagram is working now on all three incarnations of Brave on my MacBook Air (2015 13") running MacOS X Mojave 10.14.3:

  • Brave Dev 0.62.11 Chromium: 73.0.3683.39 (Official Build) dev (64-bit,)
  • Brave Beta 0.61.36 Chromium: 73.0.3683.39 (Official Build) beta (64-bit), and
  • Brave mainline 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit)

as well as Brave mainline on Windows 10 Version 10.0.17134 Build 17134:

  • Brave mainline 0.60.45 Chromium: 72.0.3626.109 (Official Build) (64-bit) on Windows.

So looks like it’s fixed. w00+!

1 Like

#16

Thank you for addressing these issues. However, my problem about embedded Instagram posts (my thread was merged into this one) was not solved by this.
I see the pictures on instagram.com, but I don’t see these type of embedded posts which are all over the internet, only the blank box redirecting me to instagram.com.

My version of Brave Ad Block Update is 1.0.143 right now.
The issue is present with and w/o Shields, on Android, Linux and Windows as well.
Thank you for your work on Brave.

0 Likes

#17

@Mathiassa,
Apologies for the late reply.
Can you share a link to a site that displays embedded IG posts as described above?

0 Likes

#18

Hi, thank you for your reply.

For example, It doesn’t work on the site where the method is described (linked in my previous post),
or see this news report for another example:
here.

However, by randomly clicking on things, I found a site, where I see the insta post:
here.

Maybe you can compare the structure of the three sites, and found out why it is working on the random last one and not on the others.

Looking at this StackOverflow question I think the problem can be on the content makers side after all.

0 Likes

#19

Can you tell me what your Shields settings are set to for that site? I’m able to see all Instagram (and other social media) embeds on the page linked with default Shields settings.

:point_up: Same for this one. I actually went an extra step and blocked all cookies from those sites, expecting it to not like that, but it refreshed and displayed as intended. Can you also share any console output you see when you’re on either of those sites?

0 Likes

#20

Same experience with shields up and down.
I don’t have problems with facebook/twitter embeddings (or the problem with these is less frequent, I don’t know).
On the two sites without working embedding I got these on the console:
embederr1
embederr2
On the third site where the embedding somehow works there is no related error on the console.

0 Likes

#21

@Mathiassa,
I’m now thinking this may be a cache issue of some kind. Can you try going to the sites you shared previously in a Private Window?
Let me know if the pages display correctly.

0 Likes