Several extensions can't be installed (503)

Description of the issue:
How can this issue be reproduced?

  1. Try to install the Dark Reader extension (and others)
  2. Watch the browser fail

Expected result:

The extension should get installed

Brave Version( check About Brave):

1.14.83

Additional Information:

Here is the URL reported by brave:
https://go-updater.brave.com/extensions?response=redirect&os=win&arch=x64&os_arch=x86_64&nacl_arch=x86-64&prod=chromiumcrx&prodchannel=&prodversion=85.1.14.83&lang=en-GB&acceptformat=crx3&x=id%3Deimadpbcbfnmbkopoojfekhnkhdbieeh%26installsource%3Dondemand%26uc

# Error 503 Backend unavailable, connection timeout

Backend unavailable, connection timeout

### Guru Mediation:

Details: cache-pao12020-PAO 1600452632 2556076504

Varnish cache server

Ublock extra is also a problem.
Earlier, some other extensions were failing, but I was able to install them after I re-installed brave.
I can’t find a pattern.
Your status page stays things are fine.

Usually, I just install extensions from the chrome extensions store… never seen the go-updater.brave.com url…

Same here. Brave seems to intercept the URL and use its own repos.

@adjunkie,
Do you have developer mode enabled in Settings --> Extensions?

I did not. I just tried with it enabled and it didn’t change anything.

Just tried the URL from a Tor backed private window and it downloads, so it seems my normal IP is in a blocked range.
Would be useful to have a more meaningful error message. The current one makes it sound like the Brave infrastructure is having an issue.

1 Like