Settings on a per domain / URL basis


#1

Hi,

I was wondering if you plan to add per domain/URL settings at some point. I understand that you’ve recently upgraded your base engine, and it may be a feature that was there in Muon, but I didn’t come to Brave until recently.

My specific problem right now is that I’m trying to log into Spotify using Facebook Connect. The desktop app launches the login in the web browser, but when it does this in Brave, the new tab just disappears after less than a second. If there were a setting for that specific domain to allow the popups, I wouldn’t have to set the default browser to a different browser.

If anyone knows how I can get around my specific issue right now in Brave, I would appreciate any pointers, but I feel that having the option to refine settings on a per-domain / URL basis would be beneficial, perhaps including certain URLs that are known to cause issues for some users.

Thanks,


#2

Hello,

Thanks for reaching out. So I have two ideas.
First, I would recommend turning of shields then go to chrome://settings/content and turn protected content ON.
If this doesn’t work, then I would recommend download our dev version of Brave. It has all the latest features and works with Spotify web player. Download it here: https://brave.com/download-dev/

Let me know if this works!


#3

Hi @Adge,

Thanks for your quick response. I didn’t get it working in the live version of Brave, but after a bit of fiddling, it’s working in the Dev version. So thanks for that.

I understand that it’s probably not a priority, but is it in the pipeline to eventually get Brave working with the Spotify desktop app out of the box? I’m sure there are other desktop apps too that do similar things to Spotify, but Spotify is obviously a pretty popular one.

Anyway, keep up the good work!

Thanks again!


#4

Hello again,

Thank you for the kind words and I’m happy that I could help! As far as the future goes, I’m not entirely sure, but it is a common request so I believe our engineers are working on it. However, I’ll bring it up in a meeting just to make sure.


#5

@Adge - great, thanks!


#6

@eugaia,
The webapp was probably getting blocked by Brave’s Shields. Which, as it turns out, is more or less what you’re looking for with respect to “site-specific” protection settings.
You can read about Shields and how they work on a post I made while ago:

I’m guessing that you’re blocking 3rd party cookies (via Shields) which is why the Spotify window gets closed out. May also be a device recognition issue. First thing I would try is to turn Shields down and see if this allows you to authenticate into/use the Spotify app. From there, we can further narrow down the a cause of the conflict.


#7

@Mattches

I wasn’t using the webapp originally, though I am now. In the released version of Brave, even after turning off the shields and going into chrome://settings/content to check the settings there (already the defaults), it just brings up ‘Enable player in your browser’. On the dev version, this is not the case, and you can log in. However, the window launched by the desktop app still closes almost immediately with everything down in the dev version.

Interestingly, after logging into the webapp, the desktop app now also sees my account, so until you get what ever is blocking the Spotify app from launching a new tab (and it staying open and not closing almost instantly), that’s a good workaround for anyone using the dev version of Brave.

Cheers.


#8

@eugaia,
I’m glad you got it working!
I am still curious about this behavior though. Is there any way you’d be willing to take a short screen recodring of what happens when you attempt to authenticate and the window disappears (as well as the “Enable player in your browser” error message)?

It’s perfectly understandable if you don’t want to, but it would help isolate a potential bug (or confirm that there isn’t one). Let me know. If not, I’m happy to mark this thread as solved and close it off :slight_smile:


#9

@Mattches,

Yes, I’ll do that. It’s not behaviour that is consistent with other browsers, and it seems like something that shouldn’t just automatically happen IMHO, and if it does, then there should be an option on a per-URL basis to allow/disallow it.

I’ll have a look for a video screen capture app that I like. Any suggestions (Windows 10)?

Cheers.


#10

Still not entirely sure what you mean by this. Shields works on both per-domain and global levels and can be changed at will. You can also adjust per-domain content settings by manually adding sites (Settings --> Advanced --> Privacy/Security --> Content Settings)

Yessir!


#11

@Mattches

Thanks for your replies. I’ve just gone through the steps I did from deleting all the cached data, and in fact, it appears I was mistaken. It did log into Spotify in the desktop app on the dev version of Brave, but not on the live version, although it didn’t appear to have worked as before.

I had thought that Brave was just closing the tab without it doing anything, but in fact it just logged in completely behind the scenes. I believe this is a change in Spotify that I hadn’t noticed because I hadn’t used it for a while.

My apologies for bring this up when it was a non-issue.

Best wishes.


#12

No worries @eugaia!
Always happy to help :slight_smile:


closed #13