Settings for some websites not saving with this version of Brave

@markprezendes

Thank you.

  • Are you still experiencing issues?
  • Did you have to disable brave://flags/#brave-ephemeral-storage as suggested?
  • Have you checked whether the issue is present in Beta or Nightly?
1 Like

On it. Will inform once done

1 Like

Before updating my brave browser 1.29.76 to 1.29.77 I tried to reproduce the issue but couldn’t do it the issue was suddenly gone. Then I tried creating a new profile and tried to reproduce the issue and failed again. Then I updated my brave browser to 1.29.77 and tried the above procedures again and failed to recreate the issue. Couldn’t reproduce the issue on Brave Beta v 1.30.57 Chromium: 93.0.4577.58 and Brave Nightly v1.31.22 Chromium: 93.0.4577.63 as well. Didn’t try disabling brave://flags/#brave-ephemeral-storage since I couldn’t recreate the issue. Should I anyways?

1 Like

Thank you once again. No, don’t disable the flag until you face the issue as disabling the flag is currently a temporary workaround for users facing the issue.

I’ll wait a few hours before I update my comment in the Github ticket. Please, let me know if the issue appears once again :+1:

1 Like

Just noticed something really weird. That day when I encountered the issue and you suggested clearing Cookies and other site data , Cached images and files , Site and Shields Settings which I did without logging out of my accounts(accounts that are always logged in on my browser like discord, tutanota, protonmail etc) which were accessible or inaccessible(due to the bug). Right now I opened discord and I directly got signed in without entering my credentials. I was confused for a moment as to how I got signed in. To confirm it I went on opening all those websites which always stay logged in on my Brave using my bookmarks tab and all of them logged in directly and no its not my password manager as it is locked plus has autofill/auto sign in disabled. Does that mean that those site settings, cookies etc were never cleared at the first place? This is weird

This is actually the second time I receive such a weird report. Do you mind checking whether this behavior is present in your fresh (test) user profile and Beta & Nightly?

1 Like

The issue isn’t present on my test profile neither my Brave Nightly v1.31.22 Chromium: 93.0.4577.63. I was able to recreate it on Brave Beta v1.30.57 Chromium: 93.0.4577.58.

Steps to reproduce:
I opened discord, logged in to my account cleared all site settings, cache, cookies etc by selecting “All Time”, closed the browser, reopened the browser and went back to discord again.

Huh, this is a pretty weird bug. I mean, Brave isn’t super old like Chrome, Opera, etc, so it’s just possible that random bugs happen.

2 Likes

Thank you for your extraordinary assistance! I’ll mention this issue right away so developers are aware of this weird behavior as well!

2 Likes

Your welcome. Thank you too for assisting me with the previous bug. :slight_smile:

2 Likes

The issue is back :/. Looks like Brave Community and Google account(youtube, drive, gmail all google services work fine) are the only ones not affected by this

Edit: disabling brave://flags/#brave-ephemeral-storage works for all sites

1 Like

We’re investigating this issue, but as discussed disabling brave://flags/#brave-ephemeral-storage is a temp solution

2 Likes

@markprezendes

Unfortunately, I expected this outcome as a few users reported the same outcome. I’m wondering, did disabling the flag allow you to clear your browsing data?

Yes it did. I cleared everything except for cookies and other site data and site & sheild settings.

1 Like

But you can clear all browsing data in your test user profile after disabling the flag, can’t you?

image
yes everything clears but cached images and files and site and sheild settings stay at “less than 1MB” and “2 sites” regardless of how many times i clear everything as shown above. I selected time range as “All time”.

1 Like

All right, updated my comment in Github with the new details :+1:

Here we go, the issue received the highest possible priority, :crossed_fingers: for a fix in the upcoming hours/days.

1 Like

Read:

This should be fixed in the latest Brave build, Version 1.29.79 @Rethanis @markprezendes

1 Like

@fanboynz

Yep, exactly what my comment says :smiley:

P.S Mentioned the exact version in my comment in case it wasn’t clear enough.

1 Like