Settings for some websites not saving with this version of Brave

Everything was working fine yesterday. Today all of the sudden some websites aren’t keeping their settings. Feedly is one (I have to relog in every time I go to the site) and Twitch is another (I stay logged in but my theme keeps switching back to white when it was set to black.)

I’ve tried resetting to default Brave settings, disabling all extensions, turning off Brave shields, but none of this fixed it. I also tested other browsers and none of them are having any issues.

I’m using the latest version of Brave ( V1.29.76). The only thing that changed since yesterday and today is that Brave updated to a new version, so there’s a good chance something broke in this update.

Anyone else experiencing this or can test it? (i.e. change your Twitch to dark theme and then close the tab and go to Twitch and see if it revereted to white).

Do you mind checking whether clearing browsing data resolves the issue?

  1. Open brave://settings/clearBrowserData.
  2. Click on Advanced.
  3. Set Time rangeAll time.
  4. Select Cookies and other site data, Cached images and files, Site and Shields Settings.
  5. Click on Clear data.

I am having the same issue but only with mega.nz as of now. Bit hesitated to clear all site data & cookies as I have too many websites logged in. Most probably something broke in the latest update. Hope the devs fix it soon.

edit: WhatsApp Web, Dicord, Telegram, Tutanota, BitWarden & ProtonMail too

@fanboynz

Do you think the issue you reported could be related?

This morning I booted up the PC and now I’m not having any of the issues. I’m ashamed to admit I didn’t do what I always preach - reboot the computer to see if that fixes the problem. I’ll report back if the issue pops back up.

2 Likes

It’s great the issue is gone for the moment. Let us know if it appears again, it’s definitely an interesting issue.

It looks like I spoke too soon. Seemingly randomly, the issue is back.

Rebooting my computer fixed the issue, but I expect it will happen again in several hours.

Maybe, we’ll be pushing out an updated hot fix soon. Apologies for any issues

1 Like

its back for me too after it fixed after rebooting yesterday. i also cleared all cookiesm site data, cached images, files, site & sheild settings as @Rethanis told but it doesn’t work

If your issue is related to the cookies regression issue, you’ll have to wait for the upcoming Brave update. There isn’t an announced date, but since QA are already testing the build, it might as well be released later today or at some time tomorrow.

Can be tracked over here:

1 Like

Just to let you know, japaweiss opened a Github report regarding the issue. If I’m wrong about the regression issue with cookies, at least developers will be made aware of the new issue. Mentioned this thread in the Github report, too.

Also remembered developers introduced ephemeral storage changes, so asked about that too.

1 Like

All right, we have a reply from a developer.

It looks like something is going on with localStorage after some time. I’m trying to reproduce this locally, but haven’t got any result yet. It doesn’t look like it’s cookie related.
The change that touched localStorage and possibly the culprit is this: brave/brave-core#9402

@Synozeer @markprezendes

If you could provide more details or even better - steps to reproduce the issue, I’ll be happy to forward your reply so developers can look into the issue as soon as possible. Of course, feel free to post in Github on your behalf if you would like to do so.

1 Like

Thanks for the follow up. Unfortunately I don’t know how to reproduce it. Most of the time it just happens - sometimes after several hours, sometimes immediately. Rebooting fixed it at least one time, but not others.

1 Like

@Synozeer @markprezendes

First, please update your browsers to the latest version as we just got an update.
Second, please test whether you’re experiencing this issue in a fresh user profile - Create a new profile to help Troubleshoot.

2 Likes

As per developers’ suggestion, check whether disabling brave://flags/#brave-ephemeral-storage resolves the issue. It’s a recommended temporary solution.

Also, do you mind checking whether you’re having any issues in Brave Beta or Brave Nightly without disabling any flags? That will help developers find the issue easier and commit a fix.

https://brave.com/download-beta/
https://brave.com/download-nightly/

Update:

Are you still experiencing issues? Got reports both Feedly and Discord work normally today.

1 Like

Steps to reproduce the issue:

As @Synozeer mentioned, it just happens randomly. I log in to a website and I’m supposed to stay logged in but when I open a new tab and open the same website, the website opens logged out asking me for credentials again. Also If i log in to the website and later again visit the website, its logged out.

1 Like

@markprezendes

Thank you.

  • Are you still experiencing issues?
  • Did you have to disable brave://flags/#brave-ephemeral-storage as suggested?
  • Have you checked whether the issue is present in Beta or Nightly?
1 Like

On it. Will inform once done

1 Like

Before updating my brave browser 1.29.76 to 1.29.77 I tried to reproduce the issue but couldn’t do it the issue was suddenly gone. Then I tried creating a new profile and tried to reproduce the issue and failed again. Then I updated my brave browser to 1.29.77 and tried the above procedures again and failed to recreate the issue. Couldn’t reproduce the issue on Brave Beta v 1.30.57 Chromium: 93.0.4577.58 and Brave Nightly v1.31.22 Chromium: 93.0.4577.63 as well. Didn’t try disabling brave://flags/#brave-ephemeral-storage since I couldn’t recreate the issue. Should I anyways?

1 Like

Thank you once again. No, don’t disable the flag until you face the issue as disabling the flag is currently a temporary workaround for users facing the issue.

I’ll wait a few hours before I update my comment in the Github ticket. Please, let me know if the issue appears once again :+1:

1 Like