Setting default currency not working


I have successfully connected my Uphold account to my Brave Rewards Creators account. I am also successfully verified on Uphold. However, I cannot choose the deposit currency. The popup keeps asking me which currency I would like to use. No matter what I choose (preferably BAT, but other currencies do not work either) the popup keeps on reappearing and asking me about my deposit currency. It somehow does not get saved. I tried various browser, but it changes nothing. How to set the default currency to BAT so we can finally get our Brave referral link? Thank you.

Thanks for reporting. What OS and Brave version are you using?

I am using Version 1.12.105 Chromium: 84.0.4147.105 (Official Build) unknown (64-bit)
on Linux (Manjaro). However, I tried it on latest Windows 10 Version and latest Firefox Browser, too with the same results.

I’m having exactly the same problem here. Tried it with latest versions of Brave browser, Edge, Chrome and Firefox. All have the same issue… you select BAT (or any other currency), press SAVE, the popup closes, and a couple of seconds later it appears again. Stuck in an endless loop.
Is there a workaround to this?

I do not know of one.
Any solution to this @steeven ?

Just to add… I’ve just tried using Safari on an iPad and the problem is still the same. It doesn’t seem to be either browser or platform specific.

Chrome and Firefox on iPad also not working. That’s 6 browsers and 2 OS’s tested (+ @gforsi’s config). This bug is stopping anyone who experiences it from setting themselves up to use Brave Rewards.

I’ve been having the same issue. I’ve tested the newest version of Brave browser, Opera GX, chrome, all of the above. Not a browser issue as it seems.

Any news on this? Or is this just being ignored?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.