Setting brave as default browser causes Firefox to be launched instead

bug

#1

Summary

After installing brave, it asks if you want to set it as your default browser. Whether doing this at this time, or later through the settings menu, whenever a link is clicked from some other program that’s expected to launch the default browser (e.g. Mozilla Thunderbird), Firefox ends up getting launched instead.

I have Firefox, Chromium, and Brave installed side-by-side. This issue was not observed when either Firefox or Chrome were set as the default browser. However, now that I’ve changed from Chrome to Brave as my default, clicking external links causes Firefox to be launched instead.

This is under Ubuntu.

Steps to Reproduce

One way in which I ran into this issue was by clicking links in my emails, which I access through Thunderbird.

  1. Set brave as the “default browser”
  2. Open another program expected to launch your default browser when a link is clicked (e.g. Thunderbird for emails)
  3. Click a URL expected to open a web page

Expected Behavior

I expected Brave to launch if it wasn’t running already, or open a new tab otherwise.

Observed Behavior

The Firefox browser is launched instead.

Version Information

Brave: 0.19.53 
rev: e09025bf61debc46c03459def2501b3367f182d7 
Muon: 4.4.29 
libchromiumcontent: 61.0.3163.100 
V8: 6.1.534.41 
Node.js: 7.9.0 
Update Channel: Release 
OS Platform: Linux 
OS Release: 4.10.0-35-generic 
OS Architecture: x64

#2

Thanks for reporting @zsh! :lion:

I found an open maybe related issue
https://github.com/brave/browser-laptop/issues/11562

I added your comment as +1 and you can track the progress there.
Thanks,
:slight_smile:


#3

I’m also using KDE/Plasma as my desktop manager. The output for the xdg-* commands is below:

$ xdg-settings get default-web-browser
brave.desktop
$ xdg-settings check default-web-browser brave.desktop
yes
$ xdg-settings get default-url-scheme-handler http
brave.desktop
$ xdg-settings get default-url-scheme-handler https 
brave.desktop
$ xdg-settings check default-url-scheme-handler http brave.desktop
yes
$ xdg-settings check default-url-scheme-handler https brave.desktop 
yes

Unlike the GitHub issue report, which shows Plasma still marking the default browser as Firefox, Plasma in my machine had brave set in the field already, as shown in the screenshot below.

I’ll note that this is on a Laptop, not a desktop, which may or may not make a difference. Feel free to add this information there, as I’m not planning to set up a GitHub account.

(For whatever reason, I’ve noticed differences in how KDE/Plasma behaves between my desktop and laptop, though I’m not yet using Brave on my desktop due to a lack of password sync and other important features unrelated to this particular report.)


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.