Send fails with undefined ERROR

Description of the issue: Attempting to send 1 SOL token to my offline wallet.

Is the issue occurring on a specific network? NO.

What operating system are you using? win 10

Brave Version (check About Brave): 16.1.?? the latest

Additional Information: Try to send SOL to my personal offline wallet, I am able to complete/confirm the Send. Later under activity. I see that the transaction did not complete. The word ERROR in red appears in the transaction details. I tried twice over a couple days.
Why is this failing?
Why do you not have a way to attach images?

Do you not have enough gas?

1.61.xx…just released 1.61.109 today. With you not even getting numbers right, hard to know if it’s actually the latest.

You can share images…maybe pay attention to buttons here? Such as the Upload button image that’s here along with all the text editing stuff like Bold image and all.

Well, for you to say you’re trying to send Solana, should be on SOL network (or is it wrapped and another another network?). So yet again another thing you said which makes it seem like you don’t pay a lot of attention to anything. Kind of makes someone assume you’re not filling things in properly

Screenshot 2023-12-23 154543

On the SOL Network I choose to send Max SOL. If I try to send the max amount I will get a message. Insufficient balance.

insuff

So I have to manually subtract the gas. 1.000282876 minus .0000005 = 1.000277876.
I round it down to 1.000.


No messages . I click Confirm
Fail
fail

I am testing this tool with small amounts before I commit to making this my go to platform.

1 Like

ver

@jamesvessels seems like you’re not using enough gas. I was trying to look on the internet and not sure of the best sources, but like using AI it says that the gas fee should be approximately 0.00025 SOL (this is three 0s before 25). Another resource says As of December 23, 2023, the average gas fee for a simple transaction on the Solana network is around 0.0001 SOL (again, three 0’s).

You are saying you tried 0.000005 SOL (this is 5 0’s before the 5).

In other words, you are not including anywhere near enough gas fee. You should go do more research and learn how all of this works before diving into cryptocurrency.

Nope. You are wrong. The Brave wallet assigns the gas amount. there is no visible way to adjust the gas. I know crypto. I am trying to learn Brave Wallet. And you are a very poor teacher. mentor or what ever you are pretending to be.

Your ninja title is misspelled. it should be “Nunya”

1 Like

The transaction fee assigned by Brave is$.0555621
fee2
Your suggested is the appropriate amount of gas in dollars. So you are having trouble translating between Dollars and Sol.

facing the same error, do lmk if you find a fix

Hello there, found a solution to the error, get the phantom wallet, or any other, connect your brave wallet to it, and try transferring, the error won’t be caused.

I had already tried what you suggested below a number of times. And like I said earlier, I only bought 1 SOL (actually 1.000282876) to test the Brave Wallet.

Once again, Your insulting final conclusion is wrong. I see both the SOL amount and the dollar amount and am entering the correct value in the appropriate field.

I do know more than you think. I seem to know more about how SOL work in the Brave Wallet than you since you are still stuck on the idea that I am not entering the right amount of gas even after you identified the same problem.

Meanwhile, despite your help, I discovered that I could send half with no issue. So I chose HALF a couple times and on the 3rd time I altered the amount- minus gas to grab remaining total. So I now have all my SOL using the Half option.

BTW, I tried the MAX again with ½ SOL, got the gas value. Cancelled the transaction. Reselected MAX, altered the value minus the gas value. It failed again. Unspecified error in Activity.

I then chose HALF and altered the value to total remaining funds minus gas, and it succeeded.

The problem I see is that other sites, when you click Max, it takes the total amount you want to transfer minus gas and says this is how much you will have left if you choose to transfer.

The current setup here is it takes all your value then adds gas so that there is no way you can ever have sufficient funds. This is known to developers as a Bug;

Even if you go back, choose MAX, then alter the value by subtracting the gas and try to run again there is no “insufficient funds” message, the window closes as if it completed. But checking activity there is an undefined error.

I have been in Tech support for 25 years. I tried to contact support but got directed to the “community.”

The first and most important waste of our time was that You were rude, you guessed at the answers then added an insult to every conclusion. You are really bad at this.

For the Developers

It never failed selecting HALF. It failed every time selecting MAX even if you select MAX then manually subtract the gas from the total before review(I tried rounding down more than was needed for gas).

A simple solution is to set the algorithm so that when a person selects MAX, it subtracts the gas from users MAX (Total) and advise that the total you will receive is 0.9999 or whatever.

Max will always fail if it adds gas to the max. Expecting a user to request MAX then see what the gas is and cancel that transaction and re-enter the adjusted value is not the way applications should work.

Also there should never be an untrapped error in any application. A simple message that explains why the error was issued.

So,Ray, please try to be nice, ask probing question without presuming anyone’s intelligence. Go ahead and insult the person as you like but delete the personal insults before you hit send, And before you blurt out what you think might be a good answer, Investigate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.