Send error from wallet to all different addresses

Seems to be on the Eth network. Error code is
-32000: replacement transaction underpriced

You kept the template but left it blank except for additional information which you didn’t put much down on. Can’t really help you when you don’t share any information.

As I went to say that, you immediately posted one small bit of info which might help, but really do need more info. But let me try to look at this…

  1. Try adjusting gas fee. Most likely that’s wrong.

  2. Other possibility is that, there’s something going on with the network and prices changed.

Hi, I saw that after, I have adjusted the gas fees to strong as well and still comes up with the same error code. Network issue then?.

Might be. I don’t know too much when it comes to these things. I just was referencing solutions to past issues and why it was said to have resulted.

What I’m going to do is try to tag @Aman_M, who is another User who deals a lot with Brave Wallet and crypto, to see if he might know. It’s currently the weekend, so people from Brave aren’t typically active. (they usually are active here Monday through Friday)

Ok thanks a lot. I will keep researching to.

@Mr.SS Are you just trying to transfer Ethereum to another address from inside Brave wallet? Can you post a screenshot where you see this? Do you have any transactions pending?

Clear wallet transaction and nonce information on brave://settings/wallet could help. Do post an update.

USDT on Eth network from Brave wallet to another wallet. Error comes up when sending, there is no transactions pending, I cleared wallet transaction and nonce information to.

@Mr.SS A screenshot of the error would be helpful. Was your approval transaction to spend USDT token from your wallet, successful? Tagging @DouglasHDaniel for more info.

Hi, no it wasn’t successful

1 Like

Get the same error when trying to swap on a dex to.

Increase gas price.

1 Like

I have increased it to maximum.

Tagging @Mattches @Pavneet @hub for more info on -32000: replacement transaction underpriced error.

Looking into this but in the meantime, I see from your screenshots that you need to update your browser — please initiate the update and ensure you’re using the latest build of the browser.

1 Like

Thanks for looking into it, I’ll update my browser now.

Hey, yeah still no good, any thoughts

Can you please share your account address with us? You can DM it to me privately.

My theory is that there is a pending transaction stuck in the mempool that the wallet is not aware of. To have that permanently evicted from the mempool, you need to set a custom gas price that’s at least 10% higher than what was used in this pending transaction.

Here’s something you can try:

  1. Create your transaction.

  2. In the approval screen, click Edit Gas > Set custom.

  3. Take a screenshot of the screen you see next, and upload it here in case there’s something fishy going on.

  4. Increase the “Per-gas price limit (Gwei)” field to a high value, something like 2x of what it shows. Don’t worry about paying too much for the fees, because excess gas will be refunded if your transaction is successful.

    Attn: The gas estimates are refreshed every few seconds, so once you’ve made up your mind on the value you want to set, you need to enter it and click on Save fast enough, otherwise it’ll get overwritten due to a refresh.

  5. Confirm your transaction.

  6. Let us know here how it went!

Just a theory I want to rule out before digging further. Thanks for your patience!


I had the same error. Following the instruction from onyb resolved the issue. Thanks a lot!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.