Semi-random infinite loading in Hero Wars and Forge of Empires

Description of the issue:
In each of these games when I click on a button that brings up another interface, sometimes (every time when bringing up a battle screen in Hero Wars) I get an infinite loading icon. In Hero Wars, the battle resolves without my input eventually and it tells me so, but the loading screen remains. In FoE, Sometimes I can get farther (through more interface changes) without a hang, or in the case of a battle, it seems to have saved my progress so I can start where I left off.

This just started happening today, though a similar thing has happened intermittently in the past, so I initially thought it was just a local internet issue.

Hero Wars at least operates as expected if I play it in Firefox instead.
Edit: FoE is also running in Firefox without issue

I’ve already tried restarting my mode, and clearing my Brave browser cache, with no improvement.
How can this issue be reproduced?

Expected result:
Clicking on said buttons in Hero Wars should just take me to another screen, in FoE that is sometimes the case, in others it brings up another window (assigning forge points to great building, or the message board, for example) within the interface.
Brave Version( check About Brave):
110.0.5481.77 (it says up to date)

Additional Information:
Windows 10 is also up to date, Firefox may not be (I haven’t used it otherwise in quite a while)

Hello @Methos9k, thank you for bringing this to our attention. Do you see the checkmark on the up to date information? It means you have the latest one. Otherwise you need to click on it to update and then relaunch the browser.

Are you using extensions? Does the same happens in a private window? Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hope that can resolve your issue. Regards.

Yes, there’s a blue checkmark and a message “Brave is up to date”

I am not using extensions in Brave as far as I know,
[Edit: I checked Extensions under settings and none are listed]
I had some manner of adblocker and something like Brave shields in Firefox but it seemed like Brave is already doing that stuff. At least I’m not seeing ads except where I’ve lowered shields.

In a private window, Hero Wars won’t even fully load.

I disabled Hardware acceleration, and it didn’t help. I got a notification just after seeing your response that a new RTX driver was available, so I installed that and tried again (with hardware acceleration off, there was unsurprisingly no change, and turning it back on, there was no change).

I also have this problem.
The game is hero wars
This start since yesterday, 07/02/2023. Work fine if I use another browser such as chrome.
Some time the game enter with no problem but after a while in typically short load the browser can’t handle and be infinite time in there.
I playing this game for month in brave and have no problems.

I have this problem with as well. Same behavior as described above.
Did start after the latest update of brave - I am using Manjaro as OS.

I am also having this problem with Forge of empires.

Brave version
Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

When I click an item to bring up another window the game just freezes.

The browser game runs fine in Chromium Version 110.0.5481.77 (Official Build) built on Debian 11.6, running on Debian 11.6 (64-bit)

@fanboynz and @Mattches would you have any ideas on this? I tested with

While that video was uploading, I also tried on Nightly. It actually loaded smoothly and let me play a few levels. But then eventually it had me go back to redo a level and it got stuck on loading screens again. Once that happened, there was no more progression. It just froze. So where I was thinking Nightly have had a fix, now doesn’t seem to be the case.

As can be seen in the video, Chrome seems to play it smoothly with no issues. It’s kind of weird.

Yep — I’m seeing the same issues on my end. Even worse on Forge of Empires. Will be taking a look at this with @fanboynz.

The issue is between Brave & Nvidia. You can use Mozilla and Nvidia will work properly. I read about it online somewhere and used the suggestion to swap out browsers when playing FOE and no more issues. I don’t play the other game mentioned here so i can’t attest to that either way. I play on PC using Windows 10 btw.

Can you check the last Brave Chromium 109 build; (it could be related)

1 Like

I just updated Brave to the new versions today and it seemed to fix the problem in Forge of empires. With the freezing up issue.
Version 1.48.171 Chromium: 110.0.5481.177 (Official Build) (64-bit)

Hero Wars seems to have cleared up too.

Thanks for fixing it!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.