Seeing sponsored images but not registering in ad history

Briefly describe your issue:
I am seeing sponsored ads but these ads are not registering in my ads history.
Furthermore in my logs show this-
[Jun 05, 2021, 2:49:31.7 PM:ERROR:credentials_promotion.cc(503)] Token list empty
[Jun 05, 2021, 2:49:31.7 PM:ERROR:wallet.cc(162)] Claiming tokens failed
[Jun 05, 2021, 2:52:09.0 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:52:39.8 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:54:41.0 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:55:57.5 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:57:32.6 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:58:37.7 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 2:58:52.6 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 3:17:36.4 PM:ERROR:credentials_promotion.cc(503)] Token list empty
[Jun 05, 2021, 3:17:36.4 PM:ERROR:wallet.cc(162)] Claiming tokens failed
[Jun 05, 2021, 3:19:52.3 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 3:26:36.3 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 3:26:58.5 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 3:27:10.2 PM:ERROR:publisher.cc(763)] Publisher info not found
[Jun 05, 2021, 3:41:00.1 PM:ERROR:publisher.cc(763)] Publisher info not found

[Jun 05, 2021, 3:43:46.1 PM:ERROR:credentials_promotion.cc(503)] Token list empty
[Jun 05, 2021, 3:43:46.1 PM:ERROR:wallet.cc(162)] Claiming tokens failed

What Operating System and Brave version are you using (Menu --> About Brave)?
Brave 1.24.86 Chromium: 90.0.4430.212 (Official Build) (64-bit)
Revision e3cd97fc771b893b7fd1879196d1215b622c2bed-refs/branch-heads/4430@{#1429}
OS Windows 10 OS Version 2009 (Build 19042.928)

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?
18 may 2021
Have you been able to successfully receive payments in the past?
Yes i contacted @steeven and @Mattches
Are you using a VPN? (yes/no)
no

Are you in a supported region
yes

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
yes

@shivansh,
Thank you for reaching out.
Can you clarify for me – when you say “ads history” are you referring to your 7-day Ads history? Or are you referring to your estimated monthly earnings?

i am seeing sponsored images but it is not registering neither in 7 days ad history
nor in estimated monthly earnings. It is not working even after clicking the sponsored image link.

On a completly unrelated issue i am not seeing push notification ads even after enabling everything .

@shivansh,
I’ve sent you a DM – lets move this conversation there.

Thank you.

@Mattches i have the exact same error

the same is happening to me