Search results come back in the wrong language

When I do a search I my responses are in the French language. In settings I am set to English
How do I fix this?

Can you provide the requisite info. Providing more info will really help with support and troubleshooting.

Thanks

@eljuno I think I’m having the same problem. I don’t know how @Spear does his search but for me, whenever I try to search for something on the URL bar with Google as the default search engine, the search result comes out in a different language. But, if I go to google.com first, the language is English and when I search for something the result is still in English. So when you search something on the address/url bar with google as your search engine, the result comes out in a different language… not all the time but often. But when you go to the google site fire, the language is the language you prefer.

I thought it was because of the VPN I use at first, but whenever I check location, it shows the right region. Almost forgot about that thing. Thanks for posting about it @Spear.

Not sure what requisite info is. I basically type in the URL and the results I get are many search results in French. I don’t read French. My settings are set for English. I like “Brave” but this is not going to work for me. Any suggestions.