Search in Google from a provacy-aware browser?

**Description of the issue:**Highlighted text search defaults to Google instead of default search engine.
How can this issue be reproduced?

  1. Highlight text
  2. Right-click

The following options show up:

Expected result:
Search using shows up.

Brave Version( check About Brave):
Version 1.1.23 Chromium: 79.0.3945.88 (Official Build) (64-bit)

Are you sure you didn’t just switch the default search engine in the address bar? Have a look at brave://settings/searchEngines and see if Google is marked as the default one. Switching the default (Google) to another search engine did change the context menu “Search … for” option for me. (using Brave dev 1.4.47)

1 Like

You are right. Something changed my default search engine. Or maybe this happened when i had to delete my profile AGAIN because Brave could not be launched anymore.
Problem solved. Thanks!

Ah, and maybe Brave should set DDG as the default search engine on installation. And not Google,