Search history in home tab recommendations?

Why are prior searches suddenly showing up as recommendations on my home tab? This has previously shown the sites I use most often, which is helpful. Having my previous search string there is not helpful and, in some cases, not something i want everyone to see when I open a new tab. Is this an option that can be disabled?

This is on Andriod.


Hello @SingingGeek, thank you for reaching us out. If you open a new tab the homepage will show the recent websites visited or the most frequent ones but you can disable them long pressing and then tapping remove. If you want to remove all of them go to settings > new tab page > show top sites Hope this can help you. Regards.

1 Like

I understand this and liked the feayure until this morning. Now, instead of showing my most used sites, it is mixing in random searches that I’ve only executed once. Which, as mentioned in original post, is not desired. Can i stop only the addition of searches to the “frequently used” recommendations?

These are not searches I run repeatedly or anything like that. They are typical random searches - on a person or looking up the actor who played a given role, train schedules, etc. It doesnt make sense that they are showing here.


Agree with Singing geek, this has been working fine for about a year without any changes at all. The top 6 sites I visit have their icons listed, and sometimes they move around a little depending on what I read the most.

Today however, only two icons were still there, the four other were replaced by some random uninteresting search I just happened to do earlier today.
So I removed all of them, and then the next new tab I opened had some other random searches I did today or maybe yesterday. Removed them too, and again some other google searches appears…

Something has clearly changed in the last release, can we have the old functionality back please? :slightly_smiling_face:
I do lots and lots of searches for different things during my day, and when I’m done I generally never want to do them again because I’ve learnt what I wanted to know.


For what it’s worth, only google searches are showing up, no other sites.
Has the weighting/priorities of what to show the user changed somehow?

Update (since I cannot reply more than 3 times in this thread???):
I just did some testing, first by removing any matches for “google” from my history (prepare for some intensive clicking!) and then the problem disappeared from the new tab window.
Then I searched for “Test”, wait a couple of seconds, open new tab and now my top sites icons include the search for Test.

So a workaround is to clean up any matches in your history and then keep it clean :smile:

1 Like

Here’s another user reporting the same problem:


Screenshot from Brave version 1.49.122 showing the searches.
Chromium version 111.0.5563.64


It’s been doing this on my phone also, since i downloaded the new Brave update. Nothing under “settings” will make it stop.


Same here on OnePlus 6. Really annoying, it moves all my most used sites out of the way. And for us to have to click Remove every time it’s a bit silly. Also, there is no way to remove this from the widget, the proposed answer for Top Sites is not the solution for this because when you open the app it does not count as a New tab therefore it shows search results in widget. Please fix this!


This is idiotic. Brave copy/pasta’d the same issue chrome introduced 2 months ago. It was a P.I.T.A for chrome users, and it’s going to be one for Brave too. (See: Here )

To disable this “feature”:

  1. On the address bar, type: chrome://flags
  2. Search for: #organic-repeatable-queries
  3. Change drop down box to Disabled.
  4. Enjoy

P.S. - Dear Brave team,

It’s okay to disable this kind of crap for us. Really. These failed experiments Chromium has already implemented in Chrome DO NOT need to be forced upon Brave users too. Take my word for it, we would prefer it that way.

Thank you.


I just noticed this today, Google’d the issue, saw your post, did it and it worked, created an account here to login and wanted to say thanks!


Thanks for that, glad to know it’s helped. =)


Thank you so much. This worked perfectly for me.


THANK YOU so much! This worked and im so glad to have it resolved. It’s disappointing to see Brave repeating the mistakes of Chrome, though.

1 Like

To disable this, carry out the below steps: 1) Enter brave://flags/#organic-repeatable-queries in the browser address bar. 2) Set the “Organic repeatable queries in Most Visited tiles” flag to “Disabled”

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.