Search Engine and Autocomplete Issue

Description:

Under Search Engine, the Private Window option is useless as everything uses the Normal Window option. In addition, when using the Google search engine, under Appearance, the Show autocomplete suggestions in address bar choice is disregarded and will make suggestions anyway, thus being pointless to turn off.

Brave Version:
1.45.123 and 1.45.127

I am not seeing this behavior. You tagged this as both Windows and Linux but I tried in both and the feature seems to work as expected. Are you using any extensions that are allowed in Private windows?

Does this help? Search bar suggestions - Confused - #4 by JimB1

I am not on Windows at the moment, so I cannot retest there. However, I reinstalled Arch Linux along with the current (1.45.127) Brave binary release. I do not use extensions. These issues are present there.

  1. The Private Window option does not function. The Normal Window option is used for both the Normal Window and the Private Window.

  2. When the Google search engine is used, previous searches are shown in the search bar. It is not correlated with the the Show autocomplete suggestions in address bar functionality (although it would intuitively be under the Browsing History checkbox).

Could you perhaps mention which operating systems and version(s) of Brave you used that you did not have these issues with? I had installed Windows 10 22H2 and Arch Linux with 1.45.123 on both operating systems and 1.45.127 on just Arch Linux. Also, I don’t think the link you provided is related to the second issue; that link just mentions that the Top sites checkbox suggests popular sites when enabled.

No, that isn’t all it mentions. It also points out that data are sent to the selected search engine before you submit your query; this is how engine-based autocomplete works. So if you stop submitting data/characters to the engine (which is controlled by that setting), it will not be able to suggest things to you because you have not given it any hints.

I’m not sure how that helps. The option has always been off by default, so it’s not relevant.

To answer your earlier question, Win10 22H2 and Fedora 37.

Impossible to tell whether something is ‘relevant’ without knowing your configuration, people have a tendency to change settings and come to the table with a vast array of configs. As a Linux user I would have guessed you’d understand that.

I already pointed out that the link had more info than you initially got from it, but there’s no crystal ball here – if you’re just looking for shot-in-the-dark suggestions to just come back and say it’s not relevant, well – maybe we need a better process as that isn’t really a fair balance. You’ll have to help us help you.

I recommend starting by telling us more about how your settings are configured when you see the behavior, specifically the Show autocomplete suggestions in address bar as well as the 4 under that; make sure you’re on latest release (1.46.144); answer the question about extensions; and confirm that you have carefully read and understand the earlier linked thread.

Beyond that, maybe a short screen recording of the behavior would help so we can see exactly what’s happening.

To answer your earlier question, Win10 22H2 and Fedora 37.

:ok_hand:

I already pointed out that the link had more info than you initially got from it, but there’s no crystal ball here – if you’re just looking for shot-in-the-dark suggestions to just come back and say it’s not relevant, well – maybe we need a better process as that isn’t really a fair balance. You’ll have to help us help you.

I agree. I simply wanted to point out an issue that results in being misleading due to technical reasons (engine being integrated with the browser).

I recommend starting by telling us more about how your settings are configured when you see the behavior, specifically the Show autocomplete suggestions in address bar as well as the 4 under that; make sure you’re on latest release (1.46.144); answer the question about extensions; and confirm that you have carefully read and understand the earlier linked thread.

The configuration does not matter other than selecting Google for the Normal Window - Search engine used in the address bar to reproduce the issues. However, I can use default settings with no extensions, and keep neither Show autocomplete suggestions in address bar (and all checkboxes) nor Autocomplete searches and URLs as selected. I’m currently on version 1.46.153 using the Flatpak. To reproduce, select Google for the Normal Window - Search engine used in the address bar option. One issue has been reproduced since searches in a private window will now use the Google search engine. Look up any word or phrase in a normal window. Open a new tab in a normal window, and click on the search bar. Another issue has been reproduced as the word or phrase appears.