Search bar suggestions - Confused

In settings, under “Appearance”, there are four options. I have these three ticked:

Top Sites
Browsing History
Bookmarks

I am therefore confused as to why some suggestions come up. All I want is for suggestions to come up for those three items, i.e. only sites I have visited before or know/use.

I just opened a new tab and typed ig
I got suggestion for craigslist and all sorts of others, with the one i wanted at the bottom of the list (As it’s bookmarked).

How do i remove all those intermediate suggestions? I don’t want any search suggestions based on ‘what other people do online’. I want only my own stuff to be suggested. I thought my settings should achieve that but apparently not.
Any advice appreciated. thanks

That’s under Appearances → Show autocomplete suggestions in address bar. I have mine set to Browsing History and Bookmarks.

What you selected is items on the New Tab page.

No.
Maybe I didn’t explain it well enough. It’s showing me stuff like CraigsList, that shouldn’t exist anywhere, i have never visited it in my life. Its suggesting all sorts of other stuff. They look like web suggestions, i shouldn’t have those since i only ticked top sites, browsing history and bookmarkes, none of those should bring up search engine suggestions. Besides, I unticked them all and it still does it, the only way i can stop it happening is if i untick “show autocomplete suggestions in address bar”, and that then shows nothing, so i can’t get bookmarkes/topsites/browsinghistory suggestions WITHOUT those web suggestions which are useless and annoying!

I think they need to edit the settings layout so the web/search suggestinos can be off while the bookmarks and history suggestions stay on.

1 Like

Probably what you want, is to re-enable those options, but disable this one:

image

3 Likes

how to turn off this in mobile?

Danke vielmals für die Info dazu und bitte Sie um eine Entschuldigung zu dem was ich hierzu gelesen habe und natürlich möchte ich auch sehr gerne etwas dazu beitragen nur zur Zeit ist mein Budget noch nicht so gut wie ich es gerne hätte aber ich denke mal, dass ich immerhin etwas Spenden kann aber leider erst im Dezember oder ist das nicht möglich :heart: :grinning: :wink:?? Es wäre sehr hilfreich, wenn ich eine kurze Rückmeldung bekommen könnte ich bedanke mich jetzt schon einmal im voraus bei Ihnen für das Verständnis dafür :wink: :grinning: :rose: :four_leaf_clover:.! LG.Iris Simone aus der Schweiz und unsere Adresse ist Baumgartenweg 8 5722 Gränichen (AG)mit meinem LIEBEVOLLEN Mann sowie unser Liebling Tiggi :cat: :cat2: :smiley_cat: :kissing_cat: :heart::orange_heart::heart:

I believe the solution @JimB1 proposed is correct here:

@NoMoreFirefox did the above solution fix this for you?

NO!! Am I going mad, or is my version of Brave different somehow?!

When I turn off Autocomplete searches and URLs, the others disappear, it turns them ALL OFF!

The other tickable options are subnested under that one, so i can’t have them activated without having this one activated.

Could someone try it and see what I mean? If i untick it, the other options disappear

No, these are 2 different settings, take a closer look at the screenshots posted above.

“Autocomplete [verb] searches,” vs. “Show autocomplete [noun, or adjective, depending on how you read it I suppose] suggestions.”

I see, this one is under privacy/security rather than appearance. Gotcha, thanks.

But no, that doesn’t prevent web search suggestions coming up.
I still have “craigslist.org” showing up and similar web searches showing up.

I am trying to make it so that Brave ONLY shows me suggestions from browsing history, bookmarks and top sites. NOTHING else. It looks like that’s not possible, shame.

@NoMoreFirefox,
What is the default search engine you’re using in the browser?

Hi, its DuckDuckGo
thanks

So testing on my end, I was also able to see sites like craigslist.org appear when I would type in “li” or “st” into the search bar when I set DDG as my default search engine. However, after disabling everything under the Show autocomplete suggestions option (Settings --> Appearance), I now see nothing:
Example 1:

image

Example 2:
image

I turned them back on and now I see the following:

Interestingly enough, it appears that Top sites is the specific setting here that is causing these additional options to appear. Can you please try disabling the Top sites option (shown below) while leaving the other [desired] options on and test to see if you get similar results?

2 Likes

You’ve cracked the code! Thank you, yes you’re right.

Your first point - yes I tried that but obviously i dont want to see no suggestions, just not the web ones.

Second point - yes, i turned off top sites, and now i don’t get the craigslist etc (web suggestions).

That looks like a ‘fix’, certainly fixes my issue. Obviously I won’t see my “Top Sites” but since I don’t think i use that and not really even sure what they are, that’s plenty good enough for me!
Thanks again, DAMN I LOVE Brave, it’s such a great browser

3 Likes

Glad that did the trick and sorry for the confusion. I’ve also asked the team (internally) to confirm the exact behavior/sources for that Top sites setting.

Appreciate the kinds words — have a great day!

3 Likes

I sure will, now :slight_smile:
I spent 3 hours today moving 2 friends over to Brave and showing them around, setting up shields etc. I freakin love it, and no virtue signalling shite like FF keeps showing down my throat, awesome!
Cheers

2 Likes

Hi again, just wanted to follow up on this as I think Brave is superb but one major improvement I think could be made here. Hard to explain but I will try…

When I used Firefox (for many years until recently dumping it for Brave), here’s how my browsing goes if I, say, want to open a new tab and go to Amazon to log in…

Cmd-T for a new tab (I am on Mac)
Type “Amaz” and hit ENTER.
Boom, I am on Amazon.com

But on Brave, I have to insert an extra step:

Cmd-T for a new tab
Type “Amaz”
Look at what comes up, then use cursor or mouse to select my BOOKMARKED Amazon.com, then hit ENTER.

Browsers are the same in terms of bookmarks and history. It seems that Firefox would PRIORITIZE the bookmark so i can just hit enter, as it’s a common site I go to (this applies to hundreds of sites I use regularly, Amazon I actually don’t but still applies :D)

Whereas Brave seems to prioritize the DuckDuckGo search instead, so the ENTER button defaults to a search instead of the bookmarked commonly visited site.

Any chance this could be looked at and maybe changed? It really slows down my workflow, and using the web 12 hours a day 7 days a week (research and web design work) really shows it to be a much bigger pain than it probably sounds.

If not, maybe muscle memory will take over in a few years :smiley:

You can go to your search settings in the brave menu and change the keywords for the search engines.

Currently, Brave defaults to :a in the address bar, then add your search query. So, for example, you wanted to look for men’s shoes, you could type in :a mens shoes and when you hit Enter, you’ll search for men’s shoes on Amazon’s site.

No, you misunderstand me. That’s not relevant to my point about the browser behaviour. Two pictures should help. First in Firefox, then in Brave, I will go to a new tab and type four letters: amaz

Here’s what it looks like after i type the ‘z’

Firefox:


Brave:


As you can see, identical behaviour from me produces two different results. I want it how Firefox does it.

If I now hit enter, Firefox will open Amazon.co.uk in my browser, but Brave will do a search, which is surprisingingly annoying and inefficient!

Both browsers have identical search history and bookmarks, but Brave defaults to a SEARCH, while making me use cursor/mouse to select the actual site i am trying to visit. Whereas Firefox defaults to the bookmarked site, with search option second priority. That makes more sense to me since I have already got a bookmark saved, so that’s probably what I want before a DDG search!

Hope this explains it better. Grateful if one of the browser experts/devs could tell me if I can somehow adjust this behaviour myself or if it’s just how Brave works and can’t be changed.

Thanks either way.

Okay, I see what you mean.

If you do try the :a though, you can search Amazon without having to open up the Amazon site first. But I understand that’s not what you’re used to with Firefox.