Scripts Blocked as a Button

In the legacy Muon version you were able to simply Block or Allow scripts in the Shield by clicking once on that button, it was essentially an ON/OFF switch. Now, there is a drop-down menu.

What I don’t understand is, why is there are drop down menu when you only have two options? Can we have the ON/OFF switch back? I found that more convenient.


Hopefully, this will answer your question. Right now, there are basically two options: All scripts allowed (always) or allow once and there isn’t an “allow until restart”…yet. Take a look at my post here and you’ll see that that option is in the works: Brave getting worse after update at new design and engine (A LOT of bugs inside)
If you scroll up from that post you’ll also see some shields screen shots in mattches’ posts that show the option (I think their from the dev version or a very preliminary version the developers are still testing themselves). If you scroll down from my post, mattches also answers my question and provides links.

In the mean time, you only have the two options but the third is on it’s way in a future version. In the meantime, you can do a ‘manual’ unblock until restart by selecting “All scripts allowed” and then choosing one of the following methods:
Click the lock icon on the left side of the address bar and click “Site Settings” , you’ll be able to see the individual settings of the domain you’re currently on (h/t @mattches) OR
Click the “<>!” icon in the URL bar and select “Manage” OR
Go to Settings > Privacy and security > Content settings > Javascript OR
Go to History, select Clear browsing data, select advanced and make sure “Content Settings” is selected (NOTE: this will clear ALL script exceptions for all sites you have made - don’t use this method if there are some script exeptions you want to keep)