Scatter protocol

Description of the issue:
I used the wombat crypto wallet for payments on the AtomicHub EOS website. When I want to login to the website a popup appears with the choice which wallet to use, including the wombat wallet. A week ago all worked fine but since a several days the button for the wombat wallet in the popup remains greyed out so I can’t login directly with it. I asked the wombat support and they said it’s about the support for the Scatter protocol. Further they reproduced the steps and at their side it worked.
So high-probably I have changed a setting which I don’t know of that it changes this behavior. I tried different settings but no change so
I just update the Brave browser to Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (x86_64), but the problem remains

Wombat app settings

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Install wombat wallet: https://chrome.google.com/webstore/detail/wombat-gaming-wallet-for/amkmjjmmflddogmhpjloimipbofnfjih
Create an account on Atomichub EOS: https://eos.atomichub.io/market/
Try to login with the wombat wallet

Actual Result (gifs and screenshots are welcome!):


Wallet is open but button unclickable

Expected result:
Clickable wombat wallet button (orange)

Reproduces how often:
At least 10x

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Catalina 10.15.7
Brave browser latest: Version 1.40.105 Chromium: 103.0.5060.53 (Official Build) (x86_64)

Additional Information: