Save password not prompted (second attempt)

Sorry to push but have you been able to find the root cause of this issue by any chance @Mattches ?

@vampyren,

If you were to do this and elect to save this login data in the browser, then go back into settings and re-enable https, your login data will not be remembered the next time you visit the address?

Sadly no. I did disable https and i saved the login+password and it worked as it should but once i enable https it just dont work anymore.
Feels like a bug…Have you asked your devs about it? maybe you could create a report so they can do some more digging in the code. I’m an old developer myself and i tend to test many things in parallell. At this point it feels like we have tried everything we can in term of setting and environment.

@vampyren,
Sorry for the late reply. One last test here – would you be willing to try logging in using Chrome? I’m wondering if you’ll get different results. I know you said it worked for Firefox, but Chrome is a much closer comparison and may tell us whether or not this is an upstream issue or not.

Thank you for your patience and willingness to troubleshoot.

1 Like

Sure no problem. Its a good idea.

My finding is actually very surprising (sadly not in a good way).
I tried to get to my router using Chrome and it does’t even work (latest version of Chrome).

image

In Firefox and Brave i get atleast the usual warning and can continue to login to my router…

Also one more thing i should have said earlier is that in Firefox the password is filled in as it should. So the problem from Brave and Chrome is not present in Firefox.

I tried with my NAS and could get to the login page (in Chrome) but the issue is present. It behaves just like Brave. No password save window and no key on the bar.

Did you get the same issue using your router?

1 Like

@vampyren,
When I tested, I did not get the same issue as you did. However, it seems – thanks to your diligence and testing – that this is issue is rooted in the chromium engine, rather than Brave itself. I’m forwarding this information to the rest of the time now (quite literally) and will likely open an issue for this today.

1 Like

Yes i agree with that, since its the same engine and they behave the same. Although its strange it worked out for you. I cant explain that.

Any how thanks allot for sticking out so long and the ideas. Appreciate that your reporting it. I’m sure i’m not alone with this issue out there :slight_smile:

By the way will i be able to follow the status or is it internal system you report it to?

Cheers

1 Like

@vampyren,
I’m actually not entirely sure – I’ll ask but I imagine if it’s an upstream issue it should be resolved within the next browser update.

1 Like

Thanks allot, cant wait to get this fixed, so darn annoying to pull up my password manager and copy/paste each time i want to get into the NAS.

2 Likes

I have similar issue when trying to login to local server with unauthorized SSL certificate (https://serverhostname:4343),
it does not offer to save password and there is no key icon in address bar.
In Firefox it saves password without any problem.
any suggestions? Im using latest Brave version on Windows 10

Doubt there is a fix right now. Hopefully @Mattches will let us know once Brave fixes it. And yes it works in Firefox for me too.

1 Like

@vampyren @wrkc,
No fix that I’m aware of yet (sorry for the late response, just got back from some time off), but I do have an open issue to capture all passwords not being saved/not being offered to save:

I’ve included this Community thread in the github issue. More information as it’s available – sorry for the inconvenience.

2 Likes

Thanks for the update.
The ticket was closed since its duplicate. I will follow this one:

Cheers

The same thing has been happening to me. Brave is not saving passwords, nor is offering to add new passwords anymore like it used to last year, has lost one or more passwords that were previously saved, never captured the associated email that many sites use as the username, and you can’t add new usernames/passwords/email/etc entries to the password list manually. And you can’t let Brave know that their browser fails to do this other than to come here to the essentially unmonitored forum and shout uselessly to the sky.

I have the same problem in Brave when accessing my router. Brave does NOT offer to save the password NOR does it use the user/password combination that I entered manually into the Password manager. I have to enter the user and password manually every time.

The router, accessed via a local IP address, does not have a valid SSL certificate and I have tried with the “upgrade to https” option turned off and on and the insecure site warning turned on and off.
I have checked the list of sites that I have chosen not to Save passwords and the router IP address is NOT in that list.

The Password Manager works well on other sites

Obviously not a critical problem but it has clearly been around for a long time. Any suggestions would be gratefully received
Thanks

Hi,

To troubleshoot the issue with Brave not prompting to save login credentials, start by ensuring that you are using the latest version of the browser.

Then, navigate to the browser settings and make sure that the option to save passwords is enabled.

Next, is to clear your browser data, with the history, cache, and cookies, as corrupted data can sometimes cause such issues.

Now, check if there are any website exceptions set that might be preventing password saving for specific sites, and disable any browser extensions temporarily to see if they are interfering.

It is also important to verify that the websites you are trying to log into have valid SSL certificates. You can check out the article here: https://www.ssl2buy.com/wiki/ssl-installation-checker. This article will help you determine whether you have a valid SSL certificate or not.

Once these steps are completed, try logging in again, and if the problem persists, test in Incognito Mode to isolate any potential conflicts.

I hope it is works.