'Save image as' takes nearly 20 seconds to bring up the folder I'm downloading it to


Description of the issue:
When I’m trying to save a picture with ‘save image as’ it takes way too long to bring up the folder to save it.
How can this issue be reproduced?

  1. Right click image and click Save image as…
    2fe3bc2747f3e9cc3713c2d62b33dc49

  2. Takes nearly 20 seconds (I’ve counted 16-18 seconds is most often.)

  3. Brings up usual folder after that amount of time.

Expected result:
For it to bring the folder up instantly as usual.
Brave Version( check About Brave):
Version 1.34.81 Chromium: 97.0.4692.99

Additional Information:
It has randomly started on the 21st. This makes me suspect the new update. I’ve pinned down that it’s something to do with my profile, but I have absolutely zero idea what is the problem. It works normally on Chrome, private browsing, and if I make a new profile, but I have a lot of tabs and it would be an immense pain to put everything back to normal on a new profile. PLEASE HELP WITH ANY INFO, THIS PROBLEM BUGS ME A LOT.

I have been experiencing exactly the same issue.

same issue here, at first I thought something was wrong with my pc

I just found the solution, for me it was an issue regarding the Malwarebytes Browser Guard extension.
As soon as I removed it, everything works just fine.

Yes, sorry for the late reply but this works. Idk why malwarebytes is doing it.

Came here to suggest that it may be an extension but it seems that was already discovered — great work. While it’s not entirely under our control (as we don’t make/manage MWB) I’ll inform the team of this issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.