"Save" button on "On exit clear browsing history" greyed out

  • This happened when I uninstalled and reinstalled the browser.
  • The Save button doesn’t become available when I uncheck a random option.
1 Like

Hello @TYzNGE97k9kTx4n3, welcome to the community! Can you please answer the following questions so we can further investigate the issue:

1 - What kind of device and OS do you have?
2 - Have you updated to the latest Brave version? If this is a desktop computer found at brave://version) to download the most recent one (https://brave.com/download/)

3 - A screenshot of the issue (if possible).

Regards.

1-I have Windows 11
2-I have the latest Brave version too.

This is how I solved the issue.

When I open History settings with Ctrl+H, the Save button “On exit” is greyed out. But, if I got to Settings->Privacy and Security-> Clear Browsing History path, the Save button “On exit” works.

Thanks for letting us know how you solved the issue @TYzNGE97k9kTx4n3 Regards.

I had the same issue on Ubuntu, both for the Snap version and the version downloaded from the official PPA.
Interestingly, Microsoft Edge has a similar issue when trying to do Advanced clear data. (Could this be a Chromium issue or due to a common integration approach?)
The solution to go through Settings > Privacy & Security instead of going through History seems to work for both browsers. Even though the two routes seem to go to the same clear history popup, one works and one doesn’t. And it’s only been a recent issue.

I have this same issue on Windows 10, Brave 1.45.133.

No solution to this problem has been found. What was suggested above is a workaround, not a solution. And in fact, the workaround proposed here does not work for me.