Run Browser from disk image without install fails on MacOS

After double clicking Brave-Browser.dmg,
Right click on ‘Brave’,
Choose ‘Open’
Mac OS verifies the package and presents the pop-up:

“Do you want to install Brave?”

“You’re running Brave from its disk image.
Installing it on your…”

{Don’t Install | Install}

When selecting ‘Don’t Install’, in order to run Brave only from the disk image (which used to work…) the process exits. The results below are shown, this occurs under Monterey 12.5.1
It appears there is a package and class name conflict.

Running under ‘zsh’…
(Note I switched to zsh because that was suggested when running the executable from command line. This was only done to try to troubleshoot the install.)

/Volumes/Brave\ Browser/Brave\\ Browser ;
objc[1596]: Class WebSwapCGLLayer is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/Frameworks/libANGLE-shared.dylib (0x7ffb5de56ec8) and /Volumes/Brave Browser/Brave Browser Framework.framework/Versions/ (0x114ad6568). One of the two will be used. Which one is undefined.
[1220/] UniversalExceptionRaise: (os/kern) failure (5)
[1604:259:1220/] Invalid PlatformChannel receive right
Illegal instruction: 4


Hello there @emotive Please accept my apologies for this issue. On this case, try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Be waiting for your response.

Hello Kevin,

Same response using the Beta version… as below when run from terminal.

Note: I only run from terminal after it fails so that you can see the generated exception.

MacOS % ./Brave\ Browser\ Beta
objc[67267]: Class WebSwapCGLLayer is implemented in both /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/Frameworks/libANGLE-shared.dylib (0x7ffb4d359ec8) and /Volumes/Brave Browser Beta/Brave Browser Browser Beta Framework.framework/Versions/ (0x113b03880). One of the two will be used. Which one is undefined.
[1228/] UniversalExceptionRaise: (os/kern) failure (5)
[67277:259:1228/] Invalid PlatformChannel receive right
zsh: illegal hardware instruction ./Brave\ Browser\ Beta

1 Like

@emotive does the same happen on the Nightly version? Additionally, this only happens when trying to running Brave without installing it?

Does your Mac allow you to install it?

I haven’t tried each nightly version…
Yes, this only happens when I want to run it in RAM without the full install.
The Mac does allow a full install.
I prefer to run it in RAM when needed and that is where the ‘Do not Install’ button is used.
This used to work?

One can see from the exception reported by the system that there is a class naming and/or package conflict.
This is a common/classic problem when using languages like C++ and Java for development.
Sometimes a developer uses or creates software with the same package name and the same class name that the system already has resident in its software libraries. So, when the software goes to load some part of the Brave program, it has two choices for the particular package/class name hence… the naming conflict. The class loader cannot decide which of the identically named package/classes to choose so it gives up and throws an exception.


1 Like

@emotive On that case, please try with a version previous to Version 1.46.144
to see if it’s possible to run it without installation?

You can check previous versions on our repository here

Same problem.

You have a class/package naming conflict with those used by Mac OS when running the ‘Don’t Install’ option.

I tried with V1.45.133

1 Like

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible.

This version worked.

Version 1.48.108 Chromium: 109.0.5414.61 (Official Build) nightly (x86_64)



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.