Revisiting startpage and scrolling shows raw html

Description of the issue:

After performing a search on startpage, following a link and returning to startpage, scrolling the page displays raw html at the top of the page.

How can this issue be reproduced?

  1. Perform a search on startpage
  2. Follow one of the links
  3. Return to the startpage tab
  4. Scroll the page then return to the top of the page

Expected result:

Startpage display should not change when scrolling

Brave Version( check About Brave):

Version 1.14.3 (

Mobile Device details

iPhone 6s Plus

Software version 13.3.1

Additional Information:

1 Like

Did you tried with other browser/s? Seems like Startpage issue than Brave issue.

I can’t replicate the issue in Chrome, Edge, Firefox or Safari on my iPhone.

Thanks for the confirmation, @Dangthrimble.

cc @Mattches @Aa-ron for additional help. Since I’m not using iOS.

I’m unable. to reproduce this using my iPad – Startpage displays as intended after returning to it from the link followed from the search.

@steeven – can you test on iPhone and see if you can reproduce?

Happens just about every time and has been happening for a while, whether I only turn off “Block Scripts” or fully turn off “Shields” for I have a screen capture but, as a new user, I am not allowed to upload the video!

Also happens on my iPad Air (MD786B/B) running iOS 12.4.5 and Brave 1.14.3.

@steeven @Mattches Can someone advise what I need to do to be able to submit my screen recording?

Restrictions lifted… :tada:

… but the file is too big :frowning:

I’ll try again later.

You can upload the recording to GDrive or other and share the link here, @Dangthrimble.

@steeven @Mattches

Here’s the video:

I uninstalled the app on both my iOS devices and the problem appears to have gone away.

Fortunately, because I use Brave on all my devices and have Sync enabled, I didn’t lose any of my bookmarks.

Spoke too soon. The problem has re-surfaced!

1 Like

Sorry for the late reply – the video you put on Drive has restricted access so I can’t view it. Easiest way, if you can’t upload an image or video directly into the forum, is to use


Apologies. First time I’ve tried to share a file via GDrive. Hopefully you now have access. If not, I’ll try your suggestion.


The re-install seems to have fixed the problem on the iPad but not the iPhone.

1 Like

Thank you – still investigating this one. Appreciate your patience.

Any news? This is still a problem for me.

Still a problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.