Request to allow setting whitelist of Saved Site Exceptions without browersing that page

Some website redirect to other pages if Javascript is not Enabled, for example will redirect to

Even if I manully add the item in UserPrefs it doesn’t works.

I closed Brave, edit the UserPrefs, open Brave again, it is restored to the old version.

This was mentioned in the old post but it was closed # Edit Saved Site Exceptions

1 Like

cc @rossmoody @rebron2000 for this request.

I have found a workaround :smile: :

  1. Go to about:preferences#shields
  2. Disable “Block Scripts” (Allow script)
  3. Go to the buggy website that need to allow script, wait for it to load successfully
  4. Open another window, go to about:preferences#shields
  5. Enable “Block Scripts” (Not allowing script)
  6. Go back to the (still opening) tab of the buggy website (window)
  7. Click the shield
    Now it should display as Blocked Scripts, but the scripts should be already loaded so you’re not redirected.
  8. Disable the “Block Script” Toggle Button (Allow script)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.